Encountered file conflicts when upgrading to elasticsearch 2.1.1


#1

Hi, when I tried to upgrade to elasticsearch 2.1.1, following messages were displayed. what's the best way to move forward? Thanks a lot!
warning: elasticsearch-2.1.1.rpm: Header V4 RSA/SHA1 Signature, key ID d88e42b4: NOKEY
Preparing... ########################################### [100%]
file /etc/init.d/elasticsearch from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch
file /etc/sysconfig/elasticsearch from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch
file /usr/share/elasticsearch/bin/elasticsearch from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch
file /etc/elasticsearch/elasticsearch.yml from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch
file /etc/elasticsearch/logging.yml from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch
file /usr/lib/systemd/system/elasticsearch.service from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch
file /usr/share/elasticsearch/README.textile from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch
file /usr/share/elasticsearch/bin/elasticsearch.in.sh from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch
file /usr/share/elasticsearch/bin/plugin from install of elasticsearch-2.1.1-1.noarch conflicts with file from package elasticsearch-1.6.0-1.noarch


(Geunmoon Oh) #2

It's because elasticsearch-1.6.0-1.noarch was installed already.
so ES 2.1.1 can be installed after you remove old version like below

rpm -e elasticsearch-1.6.0-1.noarch


(system) #3