Error conecting to kibana

Hi !
i can't cnnecting to kibana, can you help me

thank you

my winlogbeat.yml

winlogbeat.event_logs:

  • name: Application

  • name: Security

  • name: System

output.elasticsearch:
hosts:
- localhost:9200

output.elasticsearch:
hosts: "IP:9200"

setup.kibana:
host: "IP:5601"

logging.to_files: true
logging.files:
path: C:\Programmes Files\Winlogbeat\Logs
logging.level: info

setup.dashboards.enabled: true

If you try the same URL shown in the error message from your web browser on the Windows machine running Winlogbeat do you get back a status response from Kibana?

Is Kibana configured to listen outside of localhost? Try setting server.host: 0.0.0.0. https://www.elastic.co/guide/en/kibana/current/settings.html

hi, thank you for your reply,
it's inaccessible, and yes the server.host is 0.0.0.0,

On the kibana host you can double check the listening port with netstat -an | grep 5601. You should see a listening socket bound to 0.0.0.0.

If that's in working as expected then I would check to see if there are any firewalls.

I also notice that your config is showing two output.elasticsearch.hosts settings. You should remove one of them. But this should be affecting the setup connection to Kibana.

[root@localhost ~]# netstat -an | grep 5601
tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN

PS F:\Winlogbeat\winlogbeat-7.2.0-windows-x86_64> .\winlogbeat.exe test output -c .\winlogbeat.yml -e
2019-07-12T09:23:49.283+0200 INFO instance/beat.go:606 Home path: [F:\Winlogbeat\winlogbeat-7.2.0-windows-x86_6
4] Config path: [F:\Winlogbeat\winlogbeat-7.2.0-windows-x86_64] Data path: [F:\Winlogbeat\winlogbeat-7.2.0-windows-x86_6
4\data] Logs path: [F:\Winlogbeat\winlogbeat-7.2.0-windows-x86_64\logs]
2019-07-12T09:23:49.360+0200 INFO instance/beat.go:614 Beat ID: 3a696b66-ed6e-41ba-97ec-93e0ed5fd49f
2019-07-12T09:23:49.360+0200 INFO [index-management] idxmgmt/std.go:178 Set output.elasticsearch.index t
o 'winlogbeat-7.2.0' as ILM is enabled.
2019-07-12T09:23:49.360+0200 INFO elasticsearch/client.go:166 Elasticsearch url: http://192.168.1.X:9200
elasticsearch: http://192.168.1.178:9200...
parse url... OK
connection...
parse host... OK
dns lookup... OK
addresses: 192.168.1.X
dial up... ERROR dial tcp 192.168.1.X:9200: connectex: Une tentative de connexion a échoué car le parti connecté n
'a pas répondu convenablement au-delà d'une certaine durée ou une connexion établie a échoué car l'hôte de connexion n'a
pas répondu.

I delete one output.elasticsearch.hosts, its inaccessible :frowning:

Hi Andrew,

I solve the problem that i had.


But, i have this error now !
Can you help me please.

thank you.