Error Discover:[number_format_exception] empty String

Hi everyone

I would need some help with this error. See below the description:

In Kibana UI the "More info" displays:
Error: [number_format_exception] empty String

The verbose logs:
respons [10:05:24.541] GET /app/kibana 200 24ms - 9.0B
respons [10:05:24.588] GET /bundles/ 200 18ms - 9.0B
respons [10:05:24.591] GET /ui/favicons/favicon-16x16.png 200 16ms - 9.0B
respons [10:05:24.590] GET /bundles/ 200 27ms - 9.0B
respons [10:05:24.589] GET /bundles/ 200 40ms - 9.0B
respons [10:05:24.591] GET /bundles/vendors.bundle.js?v=16588 200 319ms - 9.0B
respons [10:05:25.266] GET /bundles/commons.bundle.js?v=16588 200 81ms - 9.0B
respons [10:05:25.425] GET /bundles/kibana.bundle.js?v=16588 200 304ms - 9.0B
log [10:05:26.280] [debug][plugin] Checking Elasticsearch version
respons [10:05:26.593] GET /api/console/api_server?sense_version=%40%40SENSE_VERSION&apis=es_5_0 200 10ms - 9.0B
respons [10:05:26.879] GET /api/saved_objects/?type=index-pattern&per_page=10000&page=1 200 8ms - 9.0B
respons [10:05:26.906] GET /plugins/kibana/assets/discover.svg 200 3ms - 9.0B
respons [10:05:26.910] GET /plugins/kibana/assets/visualize.svg 200 11ms - 9.0B
respons [10:05:26.913] GET /plugins/kibana/assets/dashboard.svg 200 12ms - 9.0B
respons [10:05:26.916] GET /plugins/timelion/icon.svg 200 13ms - 9.0B
respons [10:05:26.924] GET /plugins/kibana/assets/wrench.svg 200 7ms - 9.0B
respons [10:05:26.930] GET /plugins/kibana/assets/settings.svg 200 4ms - 9.0B
respons [10:05:27.093] GET /plugins/kibana/assets/play-circle.svg 200 5ms - 9.0B
respons [10:05:27.113] GET /bundles/ebdca7741674eca4e1fadeca157f3ae6.svg 200 3ms - 9.0B
respons [10:05:27.119] GET /ui/fonts/open_sans/open_sans_v13_latin_regular.woff2 200 3ms - 9.0B
respons [10:05:27.123] GET /api/saved_objects/?type=index-pattern&fields=title&per_page=10000&page=1 200 11ms - 9.0B
respons [10:05:27.456] POST /api/saved_objects/bulk_get 200 10ms - 9.0B
respons [10:05:27.965] GET /ui/fonts/open_sans/open_sans_v13_latin_700.woff2 200 6ms - 9.0B
respons [10:05:27.966] GET /bundles/4b5a84aaf1c9485e060c503a0ff8cadb.woff2 200 6ms - 9.0B
respons [10:05:28.151] GET /ui/favicons/favicon-16x16.png 304 4ms - 9.0B
ops [10:05:28.174] memory: 63.9MB uptime: 0:02:18 load: [0.10 0.05 0.05] delay: 0.322
respons [10:05:28.303] POST /elasticsearch/_msearch 400 7

And the full request that causes the problem, ...i think is this:
Mar 15 10:37:36 s-****-elastic1 kibana: {"type":"response","@timestamp":"2018-03-15T09:37:36Z","tags":[],"pid":229241,"method":"post","statusCode":400,"req":{"url":"/elasticsearch/_msearch","method":"post","headers":{"host":"","user-agent":"Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0","accept":"application/json, text/plain, /","accept-language":"en-GB,en;q=0.8,de;q=0.5,fr;q=0.3","accept-encoding":"gzip, deflate","referer":"","content-type":"application/x-ndjson","kbn-version":"6.2.2","content-length":"550","dnt":"1","connection":"keep-alive"},"remoteAddress":"","userAgent":"","referer":""},"res":{"statusCode":400,"responseTime":5,"contentLength":9},"message":"POST /elasticsearch/_msearch 400 5ms - 9.0B"}

I can't figure it out.

I need some more context on this. What are you trying to do that causes this error?

It just appears whenever I have any default index pattern is selected. In the Discover tab, when it loads the page, it displays the error.

The indexes are accessible from the Console and the fields are visible in the visualisations as well.


What version of Kibana are you using? What is the config of the default index pattern? Are you using any scripted fields?

Kibana 6.2.2
No scripted fields
The default index pattern is an index i have created but with .kibana i get the same behaviour and as for the id I have let kibana get an id for me but also tried to define an id myself. In all cases the same error.

I think the issue may be with the data and mapping in your index. I think that a field that is mapped as a number type in Elasticsearch has some values that are just "" instead of a number. See this post for possible resolutions: Number format Exception For string type

I was looking at that but then I have tried to setup an index without number mappings and I am running into the same issue with the default .kibana index pattern.

Maybe your .kibana index is corrupted. You could try deleting it, as it gets recreated when Kibana starts up and it is not present.

I will try it now and get back asap

Fixed! Million thanks

Great, glad you got things working.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.