Error: fail to communicate with updated API client hosts

Hi there,
I have installed the ElasticAgent on Ubuntu 18.04 LTS via the suggested commandline:

sudo ./elastic-agent install -f --kibana-url= --enrollment-token=cTZFSzFuZ0JrSlg2TXhjV1o0M1E6bUdzNVhFQktRY2lidFYyYURXTlFCQQ== --insecure

The ELK stack on has a self signing certificate so I had to provide the insecure flag.

After successful enrolment the Agent goes unhealthy.
I looked into the Agent logs and found this suspicious lines:

{"log.level":"debug","@timestamp":"2021-04-15T15:20:02.422Z","log.origin":{"":"application/action_dispatcher.go","file.line":93},"message":"Failed to dispatch action 'action_id: 44f410d0-9dfb-11eb-a0dd-054b4cf002cc, type: POLICY_CHANGE', error: fail to communicate with updated API client hosts: Get \"\": dial tcp connect: connection refused","ecs.version":"1.6.0"}

It seems like it didn't save the ELK IP address and instead is putting a default of

I have a similar issue with Windows too but let's try to focus on Ubuntu for now.

A bit late, but check your fleet settings.
Policies > Click on Policy > Settings (upper right corner)
By default, they look like that:

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.