ERROR Heap Memory


I have the following error:

[circuit_breaking_exception] [parent] Data too large, data for [<http_request>] would be [995677744/949.5mb], which is larger than the limit of [986061209/940.3mb], real usage: [995677744/949.5mb], new bytes reserved: [0/0b], usages [request=0/0b, fielddata=968/968b, in_flight_requests=0/0b, accounting=182367304/173.9mb], with { bytes_wanted=995677744 & bytes_limit=986061209 & durability="PERMANENT" }

How can increase the heap memory in my system?

Thanks and regards


How much heap have you assigned to Elasticsearch, how much does the host have?


The server has 32Gb, and I have only 1Gb assigned, by default.

I changed the parameters Xms4g and Xmx4g in the file /etc/elasticsearch/jvm.options but when I restart I get an error 500, and the only option that I don't get the error 500 is changing the previous parameters to 1Gb

What do you mean? Can you post the config file and the logs?

Fixed: I have changed the parameters Xms4g and Xmx4g in the file /etc/elasticsearch/jvm.options , in addition to the file /etc/logstash/jvm.options and when restarting it works.

Thank you

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.