Error importing Kibana dashboards

Hi, I'm new to Elastic & Kibana so this I expect is very much bad config but I can't figure out what I've gotten wrong with this.

Everything is in docker, I've a single-node deployment with transport security configured and using basic auth via the built-in accounts. Metric & filebeats are working fine except I can't get the dashboards to import via the setup.dashboard config in the .yml files. The error I get is the same from both beats containers and is below...

2021-01-06T18:34:16.981Z ERROR instance/beat.go:956 Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing directory /usr/share/metricbeat/kibana: failed to import Kibana index pattern: 1 error: error loading index pattern: returned 500 to import file: <nil>. Response: {"statusCode":500,"error":"Internal Server Error","message":"An internal server error occurred."}

I've attributed this topic against Kibana but this could be something wrong my config in metric/file beats?

Also I'm not confident I've correctly implemented transport security although everything is functioning normally from what I can tell and I'm not getting/seeing any errors other than the reason for this post?

metricbeat.yml:

seccomp.enabled: false

path.config: "/usr/share/metricbeat/config/"
path.data: "/usr/share/metricbeat/data/"
keystore.path: "${path.config}/metricbeats.keystore"

monitoring.enabled: false
monitoring.cluster_uuid: "I5NPSd8MRuGLDRhSX5rRaw"

http.enabled: true
http.host: localhost
http.port: 5066

metricbeat.config.modules:
  path: "${path.config}/modules/*.yml"
  reload.period: 10s
  reload.enabled: true

output.elasticsearch:
  protocol: "https"
  hosts: "*es.mydomain.com*:9200"
  username: elastic
  password: "*password*"
  ssl.verification_mode: full
  ssl.certificate_authorities: "/usr/share/metricbeat/config/certs/ca.crt"

setup:
  dashboards:
    enabled: false
    #index: metricbeat-*
  kibana:
    host: "*kibana.mydomain.com*:5601"
    protocol: "http"
    path: ""
    username: "kibana_system"
    password: "*password*"

elasticsearch.yml:

cluster.name: "blacknas"
node.name: "elasticsearch"
network.host: 0.0.0.0
bootstrap.system_call_filter: false
xpack.monitoring.collection.enabled: false
discovery.type: single-node
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate 
xpack.security.transport.ssl.key: /usr/share/elasticsearch/config/certs/elasticsearch.key
xpack.security.transport.ssl.certificate: /usr/share/elasticsearch/config/certs/elasticsearch.crt 
xpack.security.transport.ssl.certificate_authorities: /usr/share/elasticsearch/config/certs/ca/ca.crt
xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: "/usr/share/elasticsearch/config/certs/http/elasticsearch/http.p12"

kibana.yml:

server.name: kibana
server.host: 0.0.0.0
server.port: 5601
path.data: /usr/share/kibana/config/
elasticsearch.hosts: "*https://es.mydomain.com*:9200"
elasticsearch.username: "kibana_system"
elasticsearch.password: "*password*"
#monitoring.kibana.collection.enabled: false
elasticsearch.ssl.certificateAuthorities: "/usr/share/kibana/config/certs/elasticsearch-ca.pem"

Would appreicate any help etc so thanks in advance.

K

Welcome to our community! :smiley:

What do the Kibana logs show?

Thanks for the welcome!

I was just about to follow up...as I found the cause of the issue to be the user account I defined in the beat .yml...I'd assumed the built-in kibana_system user would carry sufficient privileges for dashboard import but it doesn't, using the built-in elastic/superuser account works for the moment.

Sorry for the time waste.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.