Error installing lang-javascript plugin in Elasticsearch 2.3.2

I tried installing the lang-javascript plugin.
I had to dowload the file from my browser, because the connection was blocked from cmd.
I used the url showed on my console: lang-js plugin
I tried to install it on my node with the file parameter on the plugin installer.
I received the following error:
ERROR: Could not find plugin descriptor '' in plugin zip
Anybody else has had this problem? If so, how did you solved it?

p,d,:The plugin for python does work in the way I am installing it.

The plugin now lives here:

Launch bin/plugin install lang-javascript and note what URL is it trying to fetch.
You might need to use --verbose option for that.

The only think that --verbose added was the SockectException message, but the link is the same as the one described on my question.

I missed the link. Sorry.

BTW this link gives 404 for me.

What command did you run to install it?

sorry, I missed a letter in the link; you can check it now.
command: plugin install file://path-to-plugin --verbose

Additional info:
If I place the zip file inside the plugins folder, I receive the message "Was the plugin build before 2.0?" along with the first message described on my question when booting ES.

I checked the zip file and it looks correct to me.

So this should work:

bin/plugin install file:./