Error installing ldap river plugin


(Tom Wilson) #1

I'm completely new to elasticsearch and am trying to put together a
proof-of-concept using LDAP as a data store.

However, I came across a problem right out of the starting gate, attempting
to install the ldap river plugin, according to the instructions here:

I got this output. What went wrong, and how do I fix it?

-tom

C:\Users\twilson\Downloads\elasticsearch-1.1.1\elasticsearch-1.1.1\bin>plugin
-install tlrx/elasticsearch-river-ldap/0.0
.2
-> Installing tlrx/elasticsearch-river-ldap/0.0.2...
Trying
http://download.elasticsearch.org/tlrx/elasticsearch-river-ldap/elasticsearch-river-ldap-0.0.2.zip...
Trying
http://search.maven.org/remotecontent?filepath=tlrx/elasticsearch-river-ldap/0.0.2/elasticsearch-river-ldap-0.0.2
.zip...
Trying
https://oss.sonatype.org/service/local/repositories/releases/content/tlrx/elasticsearch-river-ldap/0.0.2/elastics
earch-river-ldap-0.0.2.zip...
Trying
https://github.com/tlrx/elasticsearch-river-ldap/archive/v0.0.2.zip...
Trying
https://github.com/tlrx/elasticsearch-river-ldap/archive/master.zip...
Downloading ............DONE
Installed tlrx/elasticsearch-river-ldap/0.0.2 into
C:\Users\twilson\Downloads\elasticsearch-1.1.1\elasticsearch-1.1.1\pl
ugins\river-ldap
Usage:
-u, --url [plugin location] : Set exact URL to download the
plugin from
-i, --install [plugin name] : Downloads and installs listed
plugins [*]
-t, --timeout [duration] : Timeout setting: 30s, 1m, 1h...
(infinite by default)
-r, --remove [plugin name] : Removes listed plugins
-l, --list : List installed plugins
-v, --verbose : Prints verbose messages
-s, --silent : Run in silent mode
-h, --help : Prints this help message

[*] Plugin name could be:
elasticsearch/plugin/version for official elasticsearch plugins
(download from download.elasticsearch.org)
groupId/artifactId/version for community plugins (download from
maven central or oss sonatype)
username/repository for site plugins (download from github
master)

Message:
Error while installing plugin, reason: IllegalArgumentException: Plugin
installation assumed to be site plugin, but c
ontains source code, aborting installation.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/187f5738-2d27-4d8c-842d-d521934a94f1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Tom Wilson) #2

I was able to install the plugin by building it from source locally and
specifying the JAR file.

-tom

On Friday, April 18, 2014 10:50:54 AM UTC-7, Tom Wilson wrote:

I'm completely new to elasticsearch and am trying to put together a
proof-of-concept using LDAP as a data store.

However, I came across a problem right out of the starting gate,
attempting to install the ldap river plugin, according to the instructions
here:

https://github.com/tlrx/elasticsearch-river-ldap

I got this output. What went wrong, and how do I fix it?

-tom

C:\Users\twilson\Downloads\elasticsearch-1.1.1\elasticsearch-1.1.1\bin>plugin
-install tlrx/elasticsearch-river-ldap/0.0
.2
-> Installing tlrx/elasticsearch-river-ldap/0.0.2...
Trying
http://download.elasticsearch.org/tlrx/elasticsearch-river-ldap/elasticsearch-river-ldap-0.0.2.zip.
..
Trying
http://search.maven.org/remotecontent?filepath=tlrx/elasticsearch-river-ldap/0.0.2/elasticsearch-river-ldap-0.0.2
.zip...
Trying
https://oss.sonatype.org/service/local/repositories/releases/content/tlrx/elasticsearch-river-ldap/0.0.2/elastics
earch-river-ldap-0.0.2.zip...
Trying
https://github.com/tlrx/elasticsearch-river-ldap/archive/v0.0.2.zip...
Trying
https://github.com/tlrx/elasticsearch-river-ldap/archive/master.zip...
Downloading ............DONE
Installed tlrx/elasticsearch-river-ldap/0.0.2 into
C:\Users\twilson\Downloads\elasticsearch-1.1.1\elasticsearch-1.1.1\pl
ugins\river-ldap
Usage:
-u, --url [plugin location] : Set exact URL to download the
plugin from
-i, --install [plugin name] : Downloads and installs listed
plugins [*]
-t, --timeout [duration] : Timeout setting: 30s, 1m, 1h...
(infinite by default)
-r, --remove [plugin name] : Removes listed plugins
-l, --list : List installed plugins
-v, --verbose : Prints verbose messages
-s, --silent : Run in silent mode
-h, --help : Prints this help message

[*] Plugin name could be:
elasticsearch/plugin/version for official elasticsearch plugins
(download from download.elasticsearch.org)
groupId/artifactId/version for community plugins (download from
maven central or oss sonatype)
username/repository for site plugins (download from github
master)

Message:
Error while installing plugin, reason: IllegalArgumentException: Plugin
installation assumed to be site plugin, but c
ontains source code, aborting installation.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a9b28a82-b096-4893-b9f2-6e0cd95956f8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3