LDAP plugin not populating


(Tom Wilson) #1

I'm trying to set up search of LDAP objects using the ldap river plugin. I
managed to install the plugin and set up my new river, but all searches are
coming up empty. The elasticsearch stdout says:

[2014-04-18 15:00:16,904][INFO ][river.ldap ] [Silver
Scorpion] [ldap][hpd] now, ldap river null waiting for 1m ms

Why is my ldap river "null?" Maybe someone can look at this and tell me
what I'm doing wrong.

I am trying to index one LDAP object (objectClass=HCProfessional), which
resides in the container ou=HCProfessional,o=testhie,dc=hpdtest

I included a list of basic attributes, and am authenticating using the
default admin account. Here is the REST payload I sent the server

PUT http://localhost:9200/_river/hpd/_meta
{
"type" : "ldap",
"ldap" : {
"host" : "localhost",
"port" : "10389",
"ssl" : false,
"userDn" : "uid=admin,ou=users,ou=system",
"credentials" : "secret",
"baseDn" : "ou=HCProfessional,o=testhie,dc=hpdtest",
"filter" : "(objectClass=HCProfessional)",
"scope" : "subtree",
"attributes" : [
"uid",
"sn",
"cn",
"description",
"facsimileTelephoneNumber",
"gender",
"givenName",
"hcSpecialization",
"hpdMedicalRecordsDeliveryEmail",
"hpdProviderLanguageSupported",
"hpdProviderMailingAddress",
"mail",
"telephoneNumber"
],
"fields" : [
"_id",
"sn",
"cn",
"description",
"facsimileTelephoneNumber",
"gender",
"givenName",
"hcSpecialization",
"hpdMedicalRecordsDeliveryEmail",
"hpdProviderLanguageSupported",
"hpdProviderMailingAddress",
"mail",
"telephoneNumber"
],
"poll" : 60000
},
"index" : {
"index" : "hpd",
"type" : "HCProfessional"
}
}

Now, when I send what I think is a simple search command:

GET http://localhost:9200/hpd/_search

I get back this:

  1. {
  2. "took": 1,
  3. "timed_out": false,
  4. "_shards": {
  5. "total": 5,
  6. "successful": 5,
  7. "failed": 0
  8. },
  9. "hits": {
  10. "total": 0,
  11. "max_score": null,
  12. "hits": []
  13. }
  14. }

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5b4ee277-2eee-4100-a74c-67c858d0e907%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2