Error loading Monitor Management


I am currently deploying synthetic monitoring for a few applications. But when trying to enable Monitor Management, I get the following message:

Error loading Monitor Management

Monitor Management settings could not be loaded. Please contact Support.

I must clarify, that elastic, kibana, and heartbeat are deployed in docker.

Thank you so much.

Hello @Juan_Pablo_Carvajal Welcome to the Elastic discuss forum.

Would it be possible to share the network har file when you face the issue?


Hello @shahzad31 . Thanks for your answer.

I am unable to send the network har file, due to corporate confidentiality.

@Juan_Pablo_Carvajal Can you confirm the version of the Kibana you are using?

Hello @Dominique_Clarke .

I am using kibana 8.6.0. And containerized heartbeat, also with version 8.6.0.

@Juan_Pablo_Carvajal Thanks for the information, we're investigating.

In the meantime, could you check your Kibana server logs for any errors? The code path that handles enabling monitor management should report an error in the server if it encounters one.

@Juan_Pablo_Carvajal do you happen to have API keys or security turned off in your Elasticsearch settings?

Monitor management requires an API key to be created in order for our global-managed testing service to communicate back with your ES cluster. Our global-managed testing service allows you to run your monitors from locations around the world, without having to manage your own infrastructure.

However, global-managed testing locations are only available on Elasticsearch Service cluster. Since you are self-hosting your deployment, you wouldn't be able to utilize our global managed testing service to run your monitors. This makes requiring API keys to be enabled unnecessary.

Instead, you can utilize private locations and use your own managed elastic-agent and Fleet setup to run your monitors.

If it is indeed an issue with API keys being enabled on your cluster, you should find an error in your Kibana logs stating such. It should look something like " Error: Please enable API keys in kibana to use synthetics service."

Let us know if this is your challenge. We'll create a issue to tackle not requiring API keys to be enabled for self-hosted clusters.

Hi, I got the same error page.

In kibana I see the following stacktrace:

[2023-03-16T15:40:20.063+01:00][ERROR][http] Error: Unable to encrypt attribute "apiKey"
    at EncryptedSavedObjectsService.attributesToEncryptIterator (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\encrypted_saved_objects\server\crypto\encrypted_saved_objects_service.js:193:17)
    at attributesToEncryptIterator.throw (<anonymous>)
    at EncryptedSavedObjectsService.encryptAttributes (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\encrypted_saved_objects\server\crypto\encrypted_saved_objects_service.js:235:23)
    at EncryptedSavedObjectsClientWrapper.create (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\encrypted_saved_objects\server\saved_objects\encrypted_saved_objects_client_wrapper.js:30:129)
    at SecureSavedObjectsClientWrapper.create (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\security\server\saved_objects\secure_saved_objects_client_wrapper.js:77:47)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at SpacesSavedObjectsClient.create (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\spaces\server\saved_objects\spaces_saved_objects_client.js:63:12)
    at Object.setSyntheticsServiceApiKey [as set] (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\synthetics\server\legacy_uptime\lib\saved_objects\service_api_key.js:71:3)
    at generateAndSaveServiceAPIKey (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\synthetics\server\synthetics_service\get_api_key.js:141:7)
    at handler (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\synthetics\server\routes\synthetics_service\enablement.js:97:7)
    at handler (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\synthetics\server\synthetics_route_wrapper.js:84:19)
    at Router.handle (C:\tools\elastic\kibana-8.6.1\node_modules\@kbn\core-http-router-server-internal\target_node\src\router.js:141:30)
    at handler (C:\tools\elastic\kibana-8.6.1\node_modules\@kbn\core-http-router-server-internal\target_node\src\router.js:107:50)
    at exports.Manager.execute (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\toolkit.js:60:28)
    at Object.internals.handler (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\handler.js:46:20)
    at exports.execute (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\handler.js:31:20)
    at Request._lifecycle (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\request.js:371:32)
    at Request._execute (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\request.js:281:9)

When I look at API management an API key with the name 'synthetics-api-key (required for monitor management)' was created on the Realm 'reserved'.

@Gunter_Van_Damme We will take a look into it. Can you try disabling monitor management and re-enable it to see if it resolves the issue for you.


It is never enabled .
When I click the button, the error occurs and kibana says that it is disabled (as a result of this error).

@Gunter_Van_Damme do you have Kibana config encryption key set as

  encryptionKey: "min-32-byte-long-strong-encryption-key"

you can also docker en vars to set it

1 Like

Great thx. That worked.

1 Like

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.