Error log curl: (52) Empty reply from server in v8.8.2

Hello, can anyone help me?
I found error log curl: (52) Empty reply from server when entering command curl -X GET

Even though when referring to the problem of:

I have followed the instructions and still get the same error?
please solution

additional information :
i am using elasticsearch v 8.8.2 running on CentOS8


You need to provide:

  • The exact command you are running
  • Elasticsearch logs

Please don't post images of text as they are hard to read, may not display correctly for everyone, and are not searchable.

Instead, paste the text and format it with </> icon or of triple backticks (```), and check the preview window to make sure it's properly formatted before posting it. This makes it more likely that your question will receive a useful answer.

Finally, please check that you are using https instead http when running your curl command.

You have set HTTPS. Since you have accessing by http, ES will not responde.
Please try the command:
curl -k -X GET 'https://localhost:9200/'