Error showing while displaying an old dashboard


(Dor Juravski) #1

Hello, I am getting the error in the screenshot, can anyone point me in the right direction to resolve this?
It's a dashboard that worked from 5.6.x to 6.0 and nothing changed, aside from the ELK version (6.2.1)

The error text did not show any hints when I searched.

Uncaught TypeError: xScale.domain(...)[1].getTime is not a function (http://10.xx.xx.171:5601/bundles/vendors.bundle.js?v=16573:6)

Error: Uncaught TypeError: xScale.domain(...)[1].getTime is not a function (http://10.xx.xx.171:5601/bundles/vendors.bundle.js?v=16573:6)
    at window.onerror (http://10.16.172.171:5601/bundles/commons.bundle.js?v=16573:1:496140)

Update: I found the specific visualization that caused the error. It's a date field that I used as a bucket, but instead of data-histogam I used terms, and sorted and chose last X terms.

It always worked, not sure why it doesn't work now.


(Bhavya R M) #2

Hi,

I am confused. Is it working for you now?

Thanks,
Bhavya


(Dor Juravski) #3

Once I changed the bucket to date histogram (it was terms) then the error was gone.
Problem solved, but I don't understand why would 6.2.1 have a problem with a bucket that is a term --> date


(Bhavya R M) #4

@ppisljar, I am not sure whats happening here.

Thanks,
Bhavya


(Peter Pisljar) #5

if you can reproduce this again then please open an issue on https://github.com/elastic/kibana/issues

thank you


(Dor Juravski) #6

Yes I can reproduce it. As soon as I return the bucket to terms --> date I get an error.
Issue opened here.

Screenshot here. If I hit the "run" triangle I get the error.
(see error below the screenshot)


(Peter Pisljar) #7

thanks!


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.