Error toasts rendering in canvas pdfs

I saw that there was a github issue raised about it (Kibana should stop rendering security warning on PDFs on unsecured cluster · Issue #82891 · elastic/kibana · GitHub) but I was wondering if there has been a fix or workaround since then? I am on a slightly older version of Elastic (v.7.17.3) as a docker image, which seems to still have this issue (see attached screenshot). Has this been resolved in newer versions?

Hi @Krikkits. Starting with v8.0, Elastic comes with security on by default. So the second toast ("Your data is not secure") should no longer appear unless you explicitly disable security.

The first toast may still appear in the latest versions of Kibana if you have not configured the server.publicBaseUrl option in your kibana.yml file.

In either case, you should be able to click "Mute warning" and "Don't show again" respectively to hide future toasts. However, I believe these options are saved at the browser level, so they might appear again if you use a different browser or computer.

Thanks! Since it's imprinted into the generated PDF from the canvas, is there a way to mute these warnings somehow? I don't see a way to mute them before clicking "generate PDF". I don't actually get these warnings within Kibana (anymore).

Ohh, my apologies. I missed that it was happening in your reports. Have you configured the xpack.reporting.kibanaServer.hostname setting in your kibana.yml? Also, what is your setting in kibana.yml?

I believe they are not configured at the moment... It is a (unsecured) dev environment in Docker. Would I be correct in assuming that I should add xpack.reporting.kibanaServer.hostname and as an environment variable set to the Kibana URL within our docker-compose? Our ELASTICSEARCH_HOSTS is set to the elastic image: http://elastic-node:9200, is that the same as

I solved it partially by adding in SERVER_PUBLICBASEURL but the security warning still renders within the PDF. Should I add in the other properties or is the only solution to enable security? See screenshot for the current look of my PDF.

Hi @Krikkits. Enabling security on your cluster is probably the safest option.

I have not tried this, so I'm not sure if it will help. But maybe in "Advanced settings" changing the notifications:lifetime:warning to a very small number will make the toast disappear more quickly. But this affects any notifications (not just this one), so you might experience some loss of information in other cases.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.