Kibana - Security Pop Up

Hey Elastic Community team,

I hope this message finds you well. I've been facing a recurring issue with the Kibana UI, specifically related to the persistent pop-up stating "Your data is not secure." Despite clicking the option to not show it again, the pop-up keeps reappearing every time I open Kibana. This concern has raised frustration among my clients who find it disruptive.

I kindly request guidance on how to permanently resolve this matter.

Thank you for your assistance in advance. Looking forward to your prompt response and solution.

Best regards,
Kumar Abhinav

If you really don't want to use Elastic Stack security features for some reason (the Basic license is free!), you can disable this warning with security.showInsecureClusterWarning: false in your kibana.yml file.



Many thanks for this information. But I did not find any such command in the KIbana.YML file. Could you please guide me on this. ?
I can share the YML file with you to verify it.


It is not present on kibana.yml, you just need to add this line to your kibana.yml and restart kibana.

Just add this to the file:

security.showInsecureClusterWarning: false

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.