How can I turn off the security warning popup in kibana Discover UI

I'm running es/kibana 7.15.1 with security disabled in es, but the kibana discovery screen is unusable because of the constant appearance of these popups:


Is there any way to turn them off?

You can disable the warning message by explicitly turning off security, i.e. add the following in elasticsearch.yml : false

However, we'd strongly recommend you to enable security since it gives you better protection and your data could be at risk without it. But in the meantime, you can choose to opt out explicitly. If you choose to add security, you can follow our step-by-step guide .


Hi @majagrubic - thanks for your reply!

P.S. I understand its a good idea to turn on security, but this is on a firewalled test environment so it would be overkill here.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.