Error trying to edit v6 filters in v7

I upgraded everything from v6 to v7. My existing searches seem to work fine, but when I attempt to edit the filter through the UI (click on filter, then "Edit filter") a "Something went wrong" page pops up with the error below. I've tried clearing my session. Works fine if I create a new search. I've even looked at the filter in Saved Objects and looks identical to a new ones I create. Any advice?

Uncaught TypeError: Cannot read property 'label' of undefined (https://<redacted>/built_assets/dlls/vendors.bundle.dll.js:203)

Version: 7.0.0
Build: 23117
Error: Uncaught TypeError: Cannot read property 'label' of undefined (https://<redacted>/built_assets/dlls/vendors.bundle.dll.js:203)
at window.onerror (https://<redacted>/bundles/commons.bundle.js:3:1029989)

Somehow the "_references" for the filters was set to an invalid Index; I'm not sure how this happened. Exporting then doing find/replace on JSON and re-importing fixed it.

Hi James,

Can you ellaborate on this? Experiencing the same issue here.

I found this error also caused by invalid fields. I had switched from fluentd to filebeat and a few field names used in filters changed slightly. I had to export all of them and do find/replace until all fixed. Also checked all the index IDs. Reimported once fixed and eventually got it all working.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.