Coordinate Map: Cannot read property ‘filter’ of undefined


(Vikas Gopal) #1

Hi Experts,

Today my Coordinate Map is giving me the below error on Kibana page
Coordinate Map: Cannot read property ‘filter’ of undefined. It started today only yesterday It was working fine . Does anyone else facing the same issue.

Regards
Vikas


(Vikas Gopal) #2

I was thinking it is because I have upgraded from 5.3 to 5.5 causes the issue . I Can confirm this problem is with all 5.x version as I got same error on older versions too.One interesting observation is last year on 16 July 2016 MapQuest announced that they’d be discontinuing the direct tile access API that Kibana was leveraging. On Monday, July 11th, 2016 the service was discontinued, and maps in Kibana broke.

Now same situation we are facing after a Year , does this mean again contract issue or service expire ?

Regards
Vikas


(Mark Walkom) #3

Can you provide a screenshot of the error?


(Mark Walkom) #4

I just tested the service then, works fine :slight_smile:


#5

I can confirm that I get the same eroor.
Screenshot is attached.


(Mark Walkom) #6

Ahh sorry, my container was 5.4.

I can replicate this on 5.5 so let me ping people and see what's happening.


#7

Problem seems to have been corrected. It is working now.


(Mark Walkom) #8

Yes, this is now working as intended.

We've added extra monitoring for the service to help catch issues moving forward as well.


#9

Thanks !


(Vikas Gopal) #10

@warkolm

Map is again gone in kibana5.5.1 , till yesterday things were fine now it says

Regards
Vikas


(Mark Walkom) #11

I just tried it and had no problems?


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.