Error when creating email alert in Cloud

When attempting to create an email alert I get the following error:

Action failed to run

The following error was found:
error sending email
139794888578880:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332: 

Support tells me I need to updatexpack.actions.allowedHosts.

How can I get a view of the current value for this field using Kibana?

I can get the cluster settings by using:

GET _cluster/settings

1 Like

Also having this same issue on-prem. Interestingly, the old Watcher e-mail alerts work fine. Not sure if that setting goes into kibana.yml, but it could be applied with a PUT to the cluster. I'm looking into what works on my end, will report back. Also have a ticket open too.

1 Like

So, turns out this gets set in kibana.yml (reference below). I tried both the hostname and star, error still persists. Default is all (star).

xpack.actions.allowedHosts: ["*"]

Relevant article:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.