Error when generating reports

Hello,

Currently we are trying to generate a report but keep getting the error message below:

Error: Failed to decrypt report job data. Please ensure that xpack.reporting.encryptionKey is set and re-generate this report.

We have 2 instances of Kibana (Testing & Production) and each have xpack.reporting.encryptionKey set with the same value.

In our Testing instance we are able to generate a report successfully but in our Production instance we are not able to. At one point the Production instance did work for a split second in generating a report but never worked again after. We also tried generating reports with shorter time intervals but that didn't seem to fix the error.

Any idea on why we can generate reports in the Testing instance but not the Production Instance?
Thanks.

Hi @tcapp24 ,

In case both instances are running against the same elasticsearch could you please make sure both Kibana instances has , for sure, the same xpack.reporting.encryptionKey? In addition to that could you also please make sure you have the correct packages installed for your distribution? (Configure reporting in Kibana | Kibana Guide [8.3] | Elastic)

Last, are both of your Kibana instances running the same version?

Cheers

Hey @tiagocosta ,

So installed the required packages on both our testing and production kibana instances. I didn't restart the kibana instances wondering if I should restart both? The testing kibana instance still works correctly and is able to generate csv reports. Production worked for a sec I was able to generate one report but after that I got the same error again

Error: Failed to decrypt report job data. Please ensure that xpack.reporting.encryptionKey is set and re-generate this report.

Forgot to mention but our kibana instances are spun up using docker and nomad so our job definition in nomad has the configuration that is used. We set the kibana reporting settings as environment variables listed below:

            "XPACK_REPORTING_CSV_MAXSIZEBYTES": "10485760",
            "XPACK_REPORTING_ENABLED": "true",
            "XPACK_REPORTING_ENCRYPTIONKEY": "secretkey",

Wondering if the way these are set are giving me in the production instance the error up above? Both instances are using the same encryption key and are on the same version 6.8.21.

@tcapp24 I believe it is a good idea to restart the Kibana instances, yes.

In addition to that, have you also considered to upgrade into a more recent version of Kibana ?

Cheers

@tiagocosta Will restart those instances next Monday and get back to you. We have not considered upgrading as of late but we probably do need to upgrade. Will probably look to upgrade if the restart doesn't change anything.

1 Like

@tiagocosta Figured out the issue. In our Nomad job that ties to Kibana some of the nodes were not modified properly. So we just copied the Nomad Job definition and re-pasted it into the job definition and re-ran the nomad job and now we can generate csv reports in Prod instance.

Thanks for all the help