Error when installing x-pack on logstash beta2


(mbr) #1

Hello,

While trying to install x-pack on logstash beta2 (https://www.elastic.co/guide/en/logstash/6.0/installing-xpack-log.html), I encounter the following error :

ERROR: Something went wrong when installing file:E:/Beta2/x-pack-6.0.0-beta2.zip, message: no implicit conversion of nil into String

Here is the cmd that I have launched : E:\Beta2\elasticsearch\bin>"E:\Beta2\logstash\bin\logstash-plugin" install file:E:/Beta2/x-pack-6.0.0-beta2.zip

I am installing on windows server that don't have access to internet.
I had no issue installing x-pack on elasticsearch and kibana.

Could you please help me ?

Thank you,
Regards,

Martin


(Marius Dragomir) #2

Hello,

The command on windows requires double forward slashes before the path, so it should be something like this for your case:
'E:\Beta2\elasticsearch\bin>“E:\Beta2\logstash\bin\logstash-plugin” install file://E:/Beta2/x-pack-6.0.0-beta2.zip'


(mbr) #3

Hello,

Thank you very much, it worked perfectly.
I was lucky that it worked without the double forward slashes for elasticsearch and kibana...

Regards,
Martin


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.