X-pack installation in elasticsearch


(ny) #1

x-pack 5.5.0 zip file installation failure using elasticsearch-plugin.bat install file:\\ and logstash install issue Kibana install of x-pack was successful Host server is windows 2012 R2 standard 2 CPU 1.9 GHz 24 GB Ram 64 bit OS x64-based processor

E:\Bitnami\elasticsearch\bin>.\elasticsearch-plugin.bat install file:\\e:\x-pac
k-5.5.0.zip
Exception in thread "main" java.net.ConnectException: Connection timed out: conn
ect
at java.net.DualStackPlainSocketImpl.connect0(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(DualStackPlainSocketI
mpl.java:79)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.ja
va:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocket
Impl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java
:188)
at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:172)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:589)
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:668)
at sun.security.ssl.BaseSSLSocketImpl.connect(BaseSSLSocketImpl.java:173
)
at sun.net.NetworkClient.doConnect(NetworkClient.java:180)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:432)
at sun.net.www.http.HttpClient.openServer(HttpClient.java:527)
at sun.net.www.protocol.https.HttpsClient.(HttpsClient.java:264)
at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewH
ttpClient(AbstractDelegateHttpsURLConnection.java:191)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConn
ection.java:1138)
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConne
ction.java:1032)
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect
(AbstractDelegateHttpsURLConnection.java:177)
at sun.net.www.protocol.https.HttpsURLConnectionImpl.connect(HttpsURLCon
nectionImpl.java:153)
at org.elasticsearch.plugins.InstallPluginCommand.urlExists(InstallPlugi
nCommand.java:300)
at org.elasticsearch.plugins.InstallPluginCommand.getMavenUrl(InstallPlu
ginCommand.java:280)
at org.elasticsearch.plugins.InstallPluginCommand.download(InstallPlugin
Command.java:231)
at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginC
ommand.java:215)
at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginC
ommand.java:201)
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwar
eCommand.java:67)
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1
22)
at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:69)
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:1
22)
at org.elasticsearch.cli.Command.main(Command.java:88)
at org.elasticsearch.plugins.PluginCli.main(PluginCli.java:47)

E:\Bitnami\elasticsearch\bin>

E:\Bitnami\kibana\bin>.\kibana-plugin.bat install file:\\e:\x-pack-5.5.0.zip
E:\Bitnami\kibana\bin>.\kibana-plugin.bat list
x-pack@5.5.0

E:\Bitnami\kibana\bin>

E:\Bitnami\logstash\bin>.\logstash-plugin.bat file:\\e:\x-pack-5.5.0.zip
ERROR: No such sub-command 'file:\\e:\x-pack-5.5.0.zip'

See: 'bin/logstash-plugin --help'

E:\Bitnami\logstash\bin>.\logstash-plugin.bat install file:\\e:\x-pack-5.5.0.zi
p
ERROR: Something went wrong when installing file:\\e:\x-pack-5.5.0.zip, message
: bad URI(is not URI?): https://artifacts.elastic.co/downloads/logstash-plugins/
file:\\e:\x-pack-5.5.0.zip/file:\\e:\x-pack-5.5.0.zip-5.5.0.zip

E:\Bitnami\logstash\bin>


(David Roberts) #2

Try using forward slashes in the file: URLs, for example:

.\elasticsearch-plugin.bat install file:///x-pack-5.5.0.zip

That's on the assumption that the zip file is in the root directory of the same drive as the Elasticsearch installation. If it was on my desktop and I had Elasticsearch installed on the C: drive then I'd use:

.\elasticsearch-plugin.bat install file:///Users/dave/Desktop/x-pack-5.5.0.zip

X-pack installation for elasticsearch fails
(ny) #3

David,

Thank you. That worked as you posted. Have error with the following:

-XX:+HeapDumpOnOutOfMemoryError, -Delasticsearch

I am noting here but also will try to research the fix.

Norman


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.