ES 0.90.3 with MongoDB river throws NoShardAvailableActionException


(Richard Louapre) #1

With ES 0.90.3 when a MongoDB river setting is added there are a series of
NoShardAvailableActionException exception thrown (see log file attached).

The same version of MongoDB river with ES 0.90.2 does not thrown any
exceptions.

Any advice on how about solve this issue?

Thanks,
Richard.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

I saw some bw compatibility issues while working on other plugins.

Did you try to update your mongodb river project to 0.90.3 and see if everything is compiling fine?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 10 sept. 2013 à 16:37, Richard Louapre richard.louapre@gmail.com a écrit :

With ES 0.90.3 when a MongoDB river setting is added there are a series of NoShardAvailableActionException exception thrown (see log file attached).

The same version of MongoDB river with ES 0.90.2 does not thrown any exceptions.

Any advice on how about solve this issue?

Thanks,
Richard.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
<elasticsearch.log>

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Richard Louapre) #3

The plugin compiles and all uni test are successful.

BTW the plugin still works fine with ES 0.90.3 but I'd like to get rid off
the exceptions.

On Tuesday, September 10, 2013 10:40:15 AM UTC-4, David Pilato wrote:

I saw some bw compatibility issues while working on other plugins.

Did you try to update your mongodb river project to 0.90.3 and see if
everything is compiling fine?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr
| @scrutmydocs https://twitter.com/scrutmydocs

Le 10 sept. 2013 à 16:37, Richard Louapre <richard...@gmail.com<javascript:>>
a écrit :

With ES 0.90.3 when a MongoDB river setting is added there are a series of
NoShardAvailableActionException exception thrown (see log file attached).

The same version of MongoDB river with ES 0.90.2 does not thrown any
exceptions.

Any advice on how about solve this issue?

Thanks,
Richard.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.
<elasticsearch.log>

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4