Es 5.4.2.0 how to set the th percolate.size


(andy_zhou) #1

i can't add the flow config in elasticsearch.yml
thread_pool:
percolate:
size: 16
queue_size: 2000

the error is

**[2017-08-04T11:40:26,843][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] uncaught exception in thread [main]**
**org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [thread_pool.percolate.size] did you mean any of [thread_pool.get.size, thread_pool.search.size, thread_pool.force_merge.size]?**

** at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:127) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.4.2.jar:5.4.2]**
**Caused by: java.lang.IllegalArgumentException: unknown setting [thread_pool.percolate.size] did you mean any of [thread_pool.get.size, thread_pool.search.size, thread_pool.force_merge.size]?**
** at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:293) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:256) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:139) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.node.Node.(Node.java:343) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.node.Node.(Node.java:242) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:232) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:232) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:350) ~[elasticsearch-5.4.2.jar:5.4.2]**
** at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) ~[elasticsearch-5.4.2.jar:5.4.2]**
** ... 6 more**

percolate
For percolate operations. Thread pool type is fixed with a size of # of available processors, queue_size of 1000.

thanks.

i flow:
https://www.elastic.co/guide/en/elasticsearch/reference/5.4/modules-threadpool.html#modules-threadpool
percolate
For percolate operations. Thread pool type is fixed with a size of # of available processors, queue_size of 1000.


(andy_zhou) #2

and what this Meaning

refresh
For refresh operations. Thread pool type is scaling with a keep-alive of 5m and a max of min(10, (# of available processors)/2).
if cpu is 8 core, the min is 32 the max is 32*(104)?


(David Pilato) #3

Please format your code using </> icon as explained in this guide. It will make your post more readable.

Or use markdown style like:

```
CODE
```

Wrong yml format here I think. Missing indentation?


(andy_zhou) #4

in elasticsearch.yml file,can tell me the write format.
the set format is
@dadoonet
image


(David Pilato) #5

Please format your code using </> icon as explained in this guide. It will make your post more readable.

Or use markdown style like:

```
CODE
```

Don't post images for code.

I can suspect you are using tabs instead of spaces but that's just a guess.


(Martijn Van Groningen) #6

So the percolate thread pool has been removed since 5.0 and the percolator uses the search thread pool instead. The reason behind this is that the percolate api has been replaced by the percolate query that can be used in the search api.


(andy_zhou) #7

@mvg
where to see the thread pool set api ?
thanks.


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.