How i can increase thread pool queue size in Elasticsearch 5.6

thread pool queue size

how can make changes in elasticsearch.yml file for increasing thread pool queue size setting ?
i am using Elasticsearch 5.6

Please help !!

If you want to increase the maximum search thread pool queue size from the default 1000 to for instance 2000, just add the following to your Elasticsearch.yml file

thread_pool.search.max_queue_size: 2000

and then restart the node for the setting to take effect. Repeat on the other nodes in the cluster.

thanks @Bernt_Rostad
i tried that but its not working

[2018-08-23T07:04:28,079][WARN ][o.e.b.ElasticsearchUncaughtExceptionHandler] [es-master01.mykaarma.com] uncaught exception in thread [main]
org.elasticsearch.bootstrap.StartupException: java.lang.IllegalArgumentException: unknown setting [thread_pool.search.max_queue_size] did you mean any of [thread_pool.search.queue_size, thread_pool.get.queue_size, thread_pool.force_merge.queue_size]?
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:123) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.6.4.jar:5.6.4]
Caused by: java.lang.IllegalArgumentException: unknown setting [thread_pool.search.max_queue_size] did you mean any of [thread_pool.search.queue_size, thread_pool.get.queue_size, thread_pool.force_merge.queue_size]?
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:293) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.common.settings.AbstractScopedSettings.validate(AbstractScopedSettings.java:256) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.common.settings.SettingsModule.(SettingsModule.java:139) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.node.Node.(Node.java:344) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.node.Node.(Node.java:245) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap$5.(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:233) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:342) ~[elasticsearch-5.6.4.jar:5.6.4]
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.4.jar:5.6.4]
... 6 more

tried these settings too

did you mean any of [thread_pool.search.queue_size, thread_pool.get.queue_size, thread_pool.force_merge.queue_size]?

but no luck :frowning:

i want to increase this value to 2000

    "bulk" : {
      "type" : "fixed",
      "min" : 4,
      "max" : 4,
      "queue_size" : 200
    },

Before updating the bulk queue size, please read this blog post on the topic.

I'm sorry for that bad advise :frowning:

I see now that the setting I mentioned was introduced after version 5.6 (I'm currently using it in a 6.2 cluster where it works fine). I don't think the maximum queue size can be changed in 5.6, at least if I correctly understand the official Thread Pool documentation:

search
For count/search/suggest operations. Thread pool type is fixed with a size of int((# of available_processors * 3) / 2) + 1 , queue_size of 1000 .

The search thread pool queue size seems to be fixed to 1000 in version 5.6, as your failed attempts to change it proves. I see there is a thread_pool.index.size in 5.6 but that is something different, so unless you can upgrade your cluster to version 6.2 or higher I don't think you can change the search thread pool size.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.