ES Delete not freeing up disk space

I have an index in ES , with 5 shards , 0 replicas and , indexing some data
with Parent child relationship. The size of the index is 1.1 GB.
I am setting child document's id, parent , and routing value , as the
parent's ID , and parent's routing value also the same (to enable , that
both the documents go to the same shard) .

When i go and delete the child mapping , data is expected to be deleted,
which is reflected by the REST API (_Stats/_status). (shows 957 mb )

But upon checking manually , the disk space was not getting freed up .
So, i tried optimization . Although the optimization operation response was
successful, the disk space didn't get free.

By reffering to this link ;-

i tried using the curl command -

curl -XPOST ''

Although the command was run successfully , but , the response was


1 shard not either successful, nor failed.

I checked the stats/status API, the size it refleced was reduced , but disk
size was still the same.
Also , it reflected the same number of shards (successful = 4) .

After deletion when ES shows 4 successful shards , the size of the 5th
shard is (1.1 GB -957 MB).

Physically , all the 5 shards are present in the data directory. Upon
restarting the ES instance , it again shows( Stats/Status API) , 5
successful shards , and the data size is again back to 1.1 GB.

I am using elasticsearch-0.90.0.RC2 .

Please help me .Where am i going wrong ?

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to
For more options, visit