ES performance tunning

I was searching for ES performance by google and I find some documents.
They says modify ES config is good for ES performance.
So, I edit my ES config like below.

/etc/elasticsearch/elasticsearch.yml
index.number_of_replica: 0
index.number_of_shards: 3
index.translog.flush_threshold_ops: 50000
index.refresh_interval: -1
indices.memory.index_buffer_size: 50%
index.store.type: mmapfs
bootstrap.mlockall: true

/etc/default/elasticsearch
ES_HEAP_SIZE: 4g (my machine has 8g RAM)
MAX_LOCKED_MEMORY=unlimited

After configure above restart ES and LS.

# /etc/init.d/elasticsearch restart && sudo restart logstash

And make sure ES setting is correctly using curl command.

# curl 'localhost:9200/logstash-iis-test04/_settings?pretty'
{
"logstash-iis-test04" : {
"settings" : {
"index" : {
"creation_date" : "1426555104697",
"uuid" : "0PuOIGj-RnKS9cMKXbsryQ",
"number_of_replicas" : "0",
"number_of_shards" : "3",
"refresh_interval" : "5s",
"version" : {
"created" : "1010199"
}
}
}
}
}

​As you see, index.number_of_replicas and index.number_of_shards values is
correct
but , index.refresh_interval is not correct (I set this value is -1)
and another setting is not shown, where can I find another settings?

I want to see settings like index.translog.flush_threshold_ops,
index.refresh_interval, indices.memory.index_buffer_size, index.store.type,
bootstrap.mlockall..
and want to know this settings is correctly applied.

Maybe you know why this result is shown, please advice to me.

Regards

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b7f46e6b-d212-4d0d-b577-86e0056438ee%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

​Take a look at
http://www.elastic.co/guide/en/elasticsearch/reference/current/cluster.html
for other settings.

On 17 March 2015 at 00:48, Hoon Cho demantos@gmail.com wrote:

I was searching for ES performance by google and I find some documents.
They says modify ES config is good for ES performance.
So, I edit my ES config like below.

/etc/elasticsearch/elasticsearch.yml
index.number_of_replica: 0
index.number_of_shards: 3
index.translog.flush_threshold_ops: 50000
index.refresh_interval: -1
indices.memory.index_buffer_size: 50%
index.store.type: mmapfs
bootstrap.mlockall: true

/etc/default/elasticsearch
ES_HEAP_SIZE: 4g (my machine has 8g RAM)
MAX_LOCKED_MEMORY=unlimited

After configure above restart ES and LS.

# /etc/init.d/elasticsearch restart && sudo restart logstash

And make sure ES setting is correctly using curl command.

# curl 'localhost:9200/logstash-iis-test04/_settings?pretty'
{
"logstash-iis-test04" : {
"settings" : {
"index" : {
"creation_date" : "1426555104697",
"uuid" : "0PuOIGj-RnKS9cMKXbsryQ",
"number_of_replicas" : "0",
"number_of_shards" : "3",
"refresh_interval" : "5s",
"version" : {
"created" : "1010199"
}
}
}
}
}

​As you see, index.number_of_replicas and index.number_of_shards values is
correct
but , index.refresh_interval is not correct (I set this value is -1)
and another setting is not shown, where can I find another settings?

I want to see settings like index.translog.flush_threshold_ops,
index.refresh_interval, indices.memory.index_buffer_size,
index.store.type, bootstrap.mlockall..
and want to know this settings is correctly applied.

Maybe you know why this result is shown, please advice to me.

Regards

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/b7f46e6b-d212-4d0d-b577-86e0056438ee%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/b7f46e6b-d212-4d0d-b577-86e0056438ee%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEYi1X89p%3DELJC%3D1PLCjVwdx2XKboWHPKQvC2mdJ_N%2BNSPXBVA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.