Eshadoop : why lowercasing field names?

Hi
I'm a (rather impressed) user of eshadoop but I'm a bit puzzled by the
fact that all field names are lowercased prior to being sent to es and
the doc doc states : "Elasticsearch accepts only lower-case field name
and, as such, elasticsearch-hadoop will always convert Pig column names
to lower-case."
http://www.elasticsearch.org/guide/en/elasticsearch/hadoop/current/pig.html

es is perfectly fine with uppercase in field names (not in indices, but
in fields it's fine).
This is no big deal, but I'm curious of the explanation, to make sure
I'm not missing something

Thanks (both for help and nice software)

Ulul

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/54DFF1E5.4020900%40ulul.org.
For more options, visit https://groups.google.com/d/optout.

Hi,

Actually the documentation is incorrect. The problem lies mainly with Hive who treat field names as case insensitive. In
Pig the behavior was inconsistent, depending on the version and the script used.
Hence why using the mapping feature is recommended.

However, the doc needs to be corrected.

On 2/15/15 3:09 AM, Ulul wrote:

Hi
I'm a (rather impressed) user of eshadoop but I'm a bit puzzled by the fact that all field names are lowercased prior to
being sent to es and the doc doc states : "Elasticsearch accepts only lower-case field name and, as such,
elasticsearch-hadoop will always convert Pig column names to lower-case."
http://www.elasticsearch.org/guide/en/elasticsearch/hadoop/current/pig.html

es is perfectly fine with uppercase in field names (not in indices, but in fields it's fine).
This is no big deal, but I'm curious of the explanation, to make sure I'm not missing something

Thanks (both for help and nice software)

Ulul

--
Costin

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/54E07A10.5020006%40gmail.com.
For more options, visit https://groups.google.com/d/optout.