Facing Internal Server Error while accessing dashboards on Kibana

Hello Team,

We have recently upgraded ELK stack from 7.9.0 to 7.16.3 in order to close log4j vulnerability. However after upgrade while accessing kibana we are getting Internal Server Error.

ELK Versions: 7.16.3

Error stack as mentioned below.

{"type":"error","@timestamp":"2022-07-06T15:07:17+05:30","tags":,"pid":51263,"level":"error","error":{"message":"Internal Server Error","name":"Error","stack":"Error: Internal Server Error\n at HapiResponseAdapter.toError (/usr/share/kibana/src/core/server/http/router/response_adapter.js:128:19)\n at HapiResponseAdapter.toHapiResponse (/usr/share/kibana/src/core/server/http/router/response_adapter.js:82:19)\n at HapiResponseAdapter.handle (/usr/share/kibana/src/core/server/http/router/response_adapter.js:73:17)\n at Router.handle (/usr/share/kibana/src/core/server/http/router/router.js:164:34)\n at runMicrotasks ()\n at processTicksAndRejections (node:internal/process/task_queues:96:5)\n at handler (/usr/share/kibana/src/core/server/http/router/router.js:124:50)\n at exports.Manager.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/toolkit.js:60:28)\n at Object.internals.handler (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:46:20)\n at exports.execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/handler.js:31:20)\n at Request._lifecycle (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:371:32)\n at Request._execute (/usr/share/kibana/node_modules/@hapi/hapi/lib/request.js:281:9)"},"url":"http://x.x.x.x:xxxx/internal/apm/environments?start=2022-07-06T09%3A22%3A00.000Z&end=2022-07-06T09%3A37%3A19.994Z","message":"Internal Server Error"}
{"type":"response","@timestamp":"2022-07-06T15:07:17+05:30","tags":["access:apm"],"pid":51263,"method":"get","statusCode":500,"req":{"url":"/internal/apm/environments?start=2022-07-06T09%3A22%3A00.000Z&end=2022-07-06T09%3A37%3A19.994Z","method":"get","headers":{"host":"x.x.x.x:xxxx","connection":"keep-alive","kbn-version":"7.16.3","user-agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.75 Safari/537.36","content-type":"application/json","accept":"/","referer":"http://x.x.x.x:xxxx/app/apm/services?rangeFrom=now-15m&rangeTo=now&comparisonEnabled=true&comparisonType=day","accept-encoding":"gzip, deflate","accept-language":"en-US,en;q=0.9"},"remoteAddress":"x.x.x.x","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.75 Safari/537.36","referer":"http://x.x.x.x:xxxx/app/apm/services?

Anyone has any idea related to this issue?

Hi @prathameshdvk . It looks like that server error is coming from APM. Do you see anything in your browser when you try to access Kibana?

Hello Andrew,

Thanks for the reply, this issue was resolved.
Thanks.

Hi @prathameshdvk . Glad to hear it. Feel free to post any insights for others in the future.