Failed to find a usable hardware address from the network interfaces; using random bytes: 13:89:cc:a0:f7:2e:cf:b2


(Khalil Diouri) #1

I'm trying to implement elasticsearch to my remote server where I will deploy my application

when I start my elasticsearch engine with localhost is started correctly but when I change host in elasticsearch.yml to network.host: 0.0.0.0 the elasticsearch engine is stopping immediatly with the Warning

see

[2018-02-07T14:49:55,786][WARN ][i.n.u.i.MacAddressUtil   ] Failed to find a usable hardware address from the network interfaces; using random bytes: fc:b7:13:ab:f1:f7:0f:53
[2018-02-07T14:49:55,907][INFO ][o.e.t.TransportService   ] [t26r_PN] publish_address {xxx.xx.Xx.x:9300}, bound_addresses {0.0.0.0:9300}
[2018-02-07T14:49:55,919][INFO ][o.e.b.BootstrapChecks    ] [t26r_PN] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
ERROR: [1] bootstrap checks failed
[1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk

why I get this warning and why elasticsearch is stopping thanks


(David Pilato) #2

Please read https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html


(Khalil Diouri) #3

its working after adding discovery.Type: single-node but I still get the warning there is no probleme with this message ? failed to find a usable ..?

thank you so much


(David Pilato) #4

If you don't need to have a cluster of multiple nodes, that's probably fine.


(Khalil Diouri) #5

else, if I need it ,I must configure my elasticsearch engine settings ?
If you can please provide me a link for documentation thanks and have a nice day


(David Pilato) #6

You need to set network.host correctly and remove the discovery setting you just added.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.