Failed Upgrade from 1.6 to 2

Upgrading from 1.6
Single node, following instructions from

Disabled shard allocation
Sync flushed
shut down elasticsearch plus kibana and logstash to be safe
installed the new version from updated repositories
kept old configuration files
tried to start and get 'Failed' on loop

Did you install the migration plugin before upgrading and/or read Are there any clues in the ES logs?

No I did not use plugin, was not mentioned in the upgrade pages I looked at.
Nothing in logs.
I have since run the command manually to get output from running it and found 2 config errors that I have now corrected. Currently got a new error that I am trying to work out:

[2016-08-09 10:58:50,058][INFO ][bootstrap ] es.default.config is no longer supported. elasticsearch.yml must be placed in the config directory and cannot be renamed.

My config file is named and owned correctly, guessing it's another config change, but unsure at this time.

Thinking the default directory has changed.
The logs are now showing this newer error, after my initial fixes

New error, had a logging.xml config file in my config directory it didn't like.

log4j:WARN No appenders could be found for logger (bootstrap).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See for more info.

Should be logging.yml

thanks, so the error must be in my logging.xml

Got it working had to edit /etc/init.d/elasticsearch
removed '--default.config=$CONF_FILE' reference

Worked out from old forum posts.