Fatal Error after upgrading from 5.4.2 to 5.5.0


(SML) #1

After upgrading from 5.4.2 to 5.5.0, I have received a fatal error when pointing browser to http://localhost:5901

What could be the cause of this and how would I fix this?

Uncaught TypeError: Cannot read property 'register' of undefined (http://localhost:5601/bundles/kibana.bundle.js?v=1:261)
Version: 5.5.0
Build: 1
Error: Uncaught TypeError: Cannot read property 'register' of undefined (http://localhost:5601/bundles/kibana.bundle.js?v=1:261)
at window.onerror (http://localhost:5601/bundles/commons.bundle.js?v=1:90:20880)


(Mark Walkom) #2

What OS?
What does your config look like?
How did you install it?


(SML) #3

I am on OSX 10.12.5

MacBookPro (15-inch 2016) 2.9 GHz i7 16GB RAM — not sure that matters but let me know if you need more info. This is my development machine and the production server will be in Linux.

I upgraded to 5.5.0 using

brew upgrade elasticsearch
brew upgrade kibana
brew upgrade logstash

elasticsearch ran fine but kibana gives that error.

I have some custom plugins installed on the 5.4.2 but even if I have disabled them they do not run


(SML) #4

@warkolm To clarify the config, I didn’t do any custom config for it. I didn’t change the kibana.yml file so everything is default, and I did not install any plugins, including no x-pack.


(SML) #5

@warkolm This is the full error messages from the log:

{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:kibana@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:elasticsearch@5.5.0","info"],"pid":18724,"state":"yellow","message":"Status changed from uninitialized to yellow - Waiting for Elasticsearch","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:console@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:metrics@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:14Z","tags":["status","plugin:elasticsearch@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from yellow to green - Kibana index ready","prevState":"yellow","prevMsg":"Waiting for Elasticsearch"}
{"type":"log","@timestamp":"2017-07-10T06:59:15Z","tags":["status","plugin:timelion@5.5.0","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:15Z","tags":["listening","info"],"pid":18724,"message":"Server running at http://localhost:5601"}
{"type":"log","@timestamp":"2017-07-10T06:59:15Z","tags":["status","ui settings","info"],"pid":18724,"state":"green","message":"Status changed from uninitialized to green - Ready","prevState":"uninitialized","prevMsg":"uninitialized"}
{"type":"log","@timestamp":"2017-07-10T06:59:15Z","tags":["connection","client","error"],"pid":18724,"level":"error","message":"Parse Error","error":{"message":"Parse Error","name":"Error","stack":"Error: Parse Error\n    at Error (native)","code":"HPE_INVALID_METHOD"}}

(Tat Dat Pham) #6

I got same error when update full elastic Stack from v5.4.3 to v.5.5.0
OS : centos 7. I update from repo
Before update, everything worked!

When start kibana, everything is good, no warning log


(Mark Walkom) #7

Ignore that sorry.


(Bryan) #8

Could this be related to a change in how custom field-formatters are registered? I'm seeing the same error in a custom plugin after updating from 5.4.0 to 5.5.0. I think it's related to imports from 'ui/registry/field_formats'


(Mark Walkom) #9

It doesn't look like it based on https://www.elastic.co/guide/en/kibana/5.5/release-notes-5.5.0.html


(Court Ewing) #10

As @bschneiders mentioned, this seems to be related to how we're exporting module files in 5.5, which requires some updates to custom plugins before they are compatible with 5.5.0.

I put some details about this change in a comment on this issue: https://github.com/elastic/kibana/issues/12707#issuecomment-314216338


Problem about plugins
(SML) #11

@Court but how do you explain my upgrade / config right now where I still have the same issue after removing all the plugins?

I will add that I did have the old plugins when I upgraded to 5.5.0 and when the fatal error occured. But after removing them all by deleting all the folders inside ./plugins, I still have the same fatal error after restarting.


Kibana compatible plugins for 5.5.1
(Lee Drengenberg) #12

Did you use the kibana-plugin remove <your plugin> or did you just delete your plugins?

If you just deleted files from the plugins dir you might also have to delete files from the optimize directory (while Kibana is stopped). Then when you start it again it should do an optimize step that could take a couple of minutes.

Please give that a try.

Thanks,
Lee


(SML) #13

I did just delete my plugins for the plugins folder, and yes kibana did run optimize — but the fatal error remains. @LeeDr


(Lee Drengenberg) #14

Hi SML,

I think you might want to just uninstall your current Kibana install and reinstall it again.
If you have anything customized in your kibana.yml make a safe copy of that.
Uninstalling Kibana won't delete your .kibana index so you won't loose any saved searches, visualizations, or dashboards.

I'm not familiar with using brew, but you should make sure there is not any plugin files or other files left after the installation so that you know you have a clean install.

Thanks,
Lee


(SML) #15

Ok after installing re-installing all plugins, Kibana is back online. I haven’t upgraded anything and honestly don’t know what happened. That said, I should add that while it’s running fine, I still get this error:

  log   [06:21:56.071] [info][status][ui settings] Status changed from uninitialized to green - Ready
  log   [06:21:56.687] [error][client][connection] Error: Parse Error
at Error (native)

But since it is running fine right now I’ll just assume that it’s fine…


(Lee Drengenberg) #16

I'm not sure but you might possibly see that Error: Parse Error if you try to hit https://localhost:5601 (or wherever your Kibana is) when you're not running with SSL enabled (but you used https). Or the other way around.

I'm currently running Kibana with SSL enabled and I'm not seeing that error.


(SML) #17

Oh I’ve previously installed ELK with X-Pack to test stuff, then I realized that it was not a free plugin, so I have removed it. So I am unable to use https because I am not running with SSL enabled. I am using http only.


(Lee Drengenberg) #18

I don't think X-Pack is required to use SSL with Kibana, Elasticsearch, or Logstash. That's all part of the open source products. So you CAN have secure communications without X-Pack.
You just can't have user authentication/authorization with Users and Roles without X-Pack.


(SML) #19

Interesting. Thanks for your help. I will look into it.


(system) #20

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.