FATAL TypeError: Cannot read property 'version' of undefined while starting kibana

After upgrading kibana from v7.4 to v7.5, I keep getting this error
"FATAL TypeError: Cannot read property 'version' of undefined"
I'm using amazon linux and it was working great before the upgrade

I also have this error on upgrade from 7.4 to 7.5, but in own hosted environment.

root@elk01:/usr/share/kibana# sudo -u kibana bin/kibana --verbose 

 FATAL  TypeError: Cannot read property 'version' of undefined


Fixed it, it was a kibana plugin once removed, everything went back to normal

For anyone who face this issue, just make sure that your kibana plugin dir. is empty or at least try removing one by one. One of them is causing this for sure.

Check your kibana plugins directory, mine was in /usr/share/kibana/plugins
Make sure it's empty and everything should work fine

Top find! That worked for me.

root@elk01:/usr/share/kibana/plugins# ls


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.