Upgrading Kibana from 7.14.2 to 7.15.X results in error TypeError: Cannot read property 'schema' of undefined

I'm trying to upgrade Kibana on a Linux platform.

When upgrading, I am performing the following actions:

  1. Download and extract linux tar.gz file to a temp location
  2. Stop Kibana
  3. Backup existing Kibana install: sudo cp -Rp kibana kibana_backup
  4. Overwrite Kibana install with the files in the temp location
  5. Restore configuration files into updated Kibana install
  6. Confirm file and folder permissions are correct (kibana user owns logs,pid folder)
  7. Start Kibana

The result is that Kibana does not start. If I attempt to run Kibana in the foreground, I get:

$ sudo bin/kibana --verbose --allow-root
 FATAL  TypeError: Cannot read property 'schema' of undefined

I have tried this on both the integration instance and an brand new test instance.

Version info after upgrade:

$ sudo bin/kibana --version --allow-root
$ sudo bin/elasticsearch --version
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Version: 7.15.1, Build: default/tar/83c34f456ae29d60e94d886e455e6a3409bba9ed/2021-10-07T21:56:19.031608185Z, JVM: 11.0.12

Kibana Configuration

  data: /data/kibana/data
  dest: /opt/kibana/logs/kibana.log
  file: /opt/kibana/tmp/kibana.pid
  port: "5601"
  password: xxxxxxxx
  username: xxxxxxxx

Mind attaching the error message with the error stack and kibana logs as well, please?

I don't see anything in kibana.log - where would I find the "error stack"?

relevant log bits: https://drive.google.com/file/d/10mYnt9xpoPBkQyB5y5HXVugq1oVJmqU5/view?usp=sharing

I guess, in the same place when you found FATAL TypeError: Cannot read property 'schema' of undefined error message.

relevant log bits: https://drive.google.com/file/d/10mYnt9xpoPBkQyB5y5HXVugq1oVJmqU5/view?usp=sharing

I can't find TypeError: Cannot read property 'schema' of undefined error message in the file. Are you sure it's the full file?

It's not the full file; however, you are correct that the message does not appear in the log - it only appears on the console when I run kibana in the foreground.

The log is the associated log data from the time when I ran the command. Otherwise, the message is not logged.

Do you mean that Kibana crashes silently or does it function normally?
Right now it sounds like a potential bug. Would you mind creating a bug report and providing steps to reproduce the problem? Sign in to GitHub · GitHub

It crashes silently from my POV when I try and systemctl start kibana - journalctl indicates it starts successfully and then it must either hang or stop but systemctl doesn't indicate running if I check it's status. In that case (running as service), nothing at all is even logged in kibana.log.

Note: everything works just fine if I perform a rollback

If I run in the foreground it gives me the cannot read property error.

Bug Report: https://github.com/elastic/kibana/issues/117556

Issue is solved. It appears files from the old install may have been causing the issue. Moving the old install, copying back the appropriate folders, and setting the permissions corrected the issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.