FATAL Error: [config validation of [elasticsearch].username]

Hello Team,

I had Elasticsearch, Logstash and Kibana v7.16.2 with xpack security based login enabled, So today i had upgraded my ELK versions to 8.6.1 using my docker-compose file, but when i start the kibana container it always fails with below errors.

kibana           |  FATAL  Error: [config validation of [elasticsearch].username]: value of "elastic" is forbidden. This is a superuser account that cannot write to system indices that Kibana needs to function. Use a service account token instead. Learn more: https://www.elastic.co/guide/en/elasticsearch/reference/8.0/service-accounts.html

My docker-compose file's Kibana section as follows.

    image: docker.elastic.co/kibana/kibana:8.6.1
    container_name: kibana
      ELASTICSEARCH_URL: "http://elasticsearch:9200"
      ELASTICSEARCH_PASSWORD: "password1234"
      - 5601:5601
      - elasticsearch

Through online sources i had created service token by connecting my elasticsearch container. using cli

$ elasticsearch-service-tokens create elastic/kibana kibana_token
SERVICE_TOKEN elastic/kibana/kibana_token = AAEAAWVsYXNwedvZmxlZXQtc2VydmVyL3Rva2VuMTo3TFdaQED

In my compose file have replaced the password with token and tried. But it fails with same error.

Please guide me to solve this issue. Thanks.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.