FATAL Error: [config validation of [xpack.security].enabled]: definition for this key is missing

Hi
Today I've install kibana 8.1.1 on docker
and I'm facing this case with
FATAL Error: [config validation of [xpack.security].enabled]: definition for this key is missing

what's wrong with config???

version: '3.3'

services:
   kibana_1:
      container_name: kibana
      image: priv_repo/elk-docker/kibana/kibana:8.1.1

      environment:
         SERVER_NAME: kibana_new_elk
         ELASTICSEARCH_USERNAME: "elastic"
         ELASTICSEARCH_PASSWORD: "changeme"
         SERVER_PUBLICBASEURL: "http://172.23.0.2:5601/"
         ELASTICSEARCH_HOSTS: http://10.242.130.225:9202
         ELASTICSEARCH_SSL_CERTIFICATEAUTHORITIES: /usr/share/elasticsearch/config/certificates2/ca.crt
         SERVER_SSL_ENABLED: "true"
         SERVER_SSL_KEY: /usr/share/elasticsearch/config/certificates2/private.key
         SERVER_SSL_CERTIFICATE: /usr/share/elasticsearch/config/certificates2/cert.crt
         SERVER_PORT: 5601

      volumes:

       - /home/elasticsearch/certificates/es_kibana/cert.crt:/usr/share/elasticsearch/config/certificates2/cert.crt
       - /home/elasticsearch/certificates/es_kibana/private.key:/usr/share/elasticsearch/config/certificates2/private.key
       - /home/elasticsearch/certificates/ca/ca.crt:/usr/share/elasticsearch/config/certificates2/ca.crt
       - /home/elasticsearch/kickstart_elk_cluster/kibana.yml:/usr/share/kibana/config/kibana.yml

      ports:
       - "5601:5601"

      networks:
        - elastic
networks:
  elastic:
    driver: bridge
more kibana.yml
# Default Kibana configuration for docker target
server.name: kibana_new_elk
server.host: "172.23.0.2"
elasticsearch.hosts: [ "http://10.242.130.225:9202", "http://10.242.130.227:9220", "http://10.242.130.226:9239" ]
monitoring.ui.container.elasticsearch.enabled: true
xpack.security.enabled: true
#xpack.encryptedSavedObjects.encryptionKey: "WNtfmiht6uDYCsokQGh10ymJ1ViAJ7ur"

The xpack.security.enabled setting no longer exists in Kibana 8

Security is enabled by default, so you should simply remove that setting from your kibana.yml

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.