Field Data Format not working when using bucket in Visualize


#1

The field is using Btyes format, it works fine in Discovery and Average aggregation in Visualize.

Indices Pattern Page:


Average Aggregation:

But when I changed to average aggregation by Max bucket, it turns to number format. Is this normal? Or What can I do to let it display in Bytes format again?


(Felix Stürmer) #2

HI @byakuinss,

I was able to reproduce the issue, thanks for binging this to our attention. We would appreciate it if you filed a new issue on GitHub describing the problem as you did here.

In the meantime as a workaround I would suggest using the "Visual Builder" visualization type to create a "Metric" visualization:


image


#3

Hi @weltenwort

Thanks for your kindly suggestion. I will create an issue on Github of this problem.
I also tried to use the "Visual Builder" to create the Metric visualization, but I got the same issue while using both Average Aggregation and Overall Max Bucket. By the way, my elasticsearch and kibana versions are 5.4.1.



(Felix Stürmer) #4

Did you select "Bytes" as the "Data Formatter" in the metric options? Unfortunately the Visual Builder does not honor the field formatters configured in the index patterns automatically.

image


#5

Oh, I see! Sorry, I didn't notice the settings on options page.
I tried it again and it works fine. I will use Visual Builder to create Metric visualization from now on.
Very grateful for your help!


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.