Field is not matching anything in field list, but works correctly in 'table_view'


(Glenn Poston) #1

I've attached a screenshot from Kibana.

The screenshot shows a document that has a field named userIdentity.name.
If I select the filter (magnifying glass), things work as expected.
However in the field list on the left, this field does not show up.
Instead there is a field called 'name.' When i select the filter
(magnifying element) here there are no matches.

I've been working on this for a few days now and am completely stumped.
Please help!

Here is the document json:

{
"_index": "logstash-2014.02.01",
"_type": "logs",
"_id": "tthuoePDSWKiWGtGz0hrwA",
"_score": null,
"_source": {
"eventVersion": "1.0",
"userIdentity": {
"type": "IAMUser",
"principalId": "xxxxx",
"arn": "xxxxx",
"accountId": "xxxx",
"accessKeyId": "xxxx",
"userName": "xxxxx"
},
"eventTime": "2014-02-01T21:52:16Z",
"eventSource": "ec2.amazonaws.com",
"eventName": "DescribeAddresses",
"awsRegion": "us-east-1",
"sourceIPAddress": "54.204.9.62",
"userAgent": "aws-cli/1.2.6 Python/2.6.9 Linux/3.4.68-59.97.amzn1.x86_64",
"requestParameters": "{"publicIpsSet"=>{}, "filterSet"=>{}, "allocationIdsSet"=>{}}",
"responseElements": "nil",
"@version": "1",
"@timestamp": "2014-02-01T21:52:16.000Z",
"environment": "test"
},
"sort": [
1391291536000
]
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/662055b2-cedd-4604-b524-fa43c7f2241a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Glenn Poston) #2

Upgrading to milestone 4 resolved my issue. However, it appears that this
release has it's own issue... albeit relatively minor compared to the first
one. It's a css issue. Panel's in the logstash dashboard are white which
prevents reading of the white text. I updated the follwing css element
from #fff to #202328 fix.

css/bootstrap.light.min.css
.panel-container {background: #202328}

On Saturday, February 1, 2014 5:03:39 PM UTC-5, Glenn Poston wrote:

I've attached a screenshot from Kibana.

The screenshot shows a document that has a field named userIdentity.name.
If I select the filter (magnifying glass), things work as expected.
However in the field list on the left, this field does not show up.
Instead there is a field called 'name.' When i select the filter
(magnifying element) here there are no matches.

I've been working on this for a few days now and am completely stumped.
Please help!

Here is the document json:

{
"_index": "logstash-2014.02.01",
"_type": "logs",
"_id": "tthuoePDSWKiWGtGz0hrwA",
"_score": null,
"_source": {
"eventVersion": "1.0",
"userIdentity": {
"type": "IAMUser",
"principalId": "xxxxx",
"arn": "xxxxx",
"accountId": "xxxx",
"accessKeyId": "xxxx",
"userName": "xxxxx"
},
"eventTime": "2014-02-01T21:52:16Z",
"eventSource": "ec2.amazonaws.com",
"eventName": "DescribeAddresses",
"awsRegion": "us-east-1",
"sourceIPAddress": "54.204.9.62",
"userAgent": "aws-cli/1.2.6 Python/2.6.9 Linux/3.4.68-59.97.amzn1.x86_64",
"requestParameters": "{"publicIpsSet"=>{}, "filterSet"=>{}, "allocationIdsSet"=>{}}",
"responseElements": "nil",
"@version": "1",
"@timestamp": "2014-02-01T21:52:16.000Z",
"environment": "test"
},
"sort": [
1391291536000
]
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8a769dd9-b1d3-46a0-b2e8-32bb1d678b11%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3