Fields didn't show up

Hi, i'm using " Visualize data from a log file experimental" to upload a json file into kibana, but when i imported the file, it didn't display the fields contained in json file.
Here is what i get:

Here is a snippet of my json file:
My goal is to get for example "new socket", "on start" etc... as a fields to my index to explore them later.

Hi there, thanks for posting the question!

I believe you may be seeing this issue due to the spaces in the field names. This isn't something that Elasticsearch supports. Can you try again with a log file where the spaces are converted to underscores instead? For example, instead of "new socket" the field name should be "new_socket".

Hello, i converted them but still the same result.
I moved to create a config file in order to upload the data via logstash

Still the same output ! i dont know if i should add the field names in the fitler brackets or something else like that. If you can help me to solve this problem, thank you very much.

Using logstash you can add a mutate filter to rename these fields. Here is the documentation:

An example might be:

filter {
  mutate {
    rename => {
      "new socket" => "new_socket",
      "end socket" => "end_socket",
      "[onStart][number of online devices]" => "[onStart][number_of_online_devices]"

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.