Filebeat high cpu load on Win 2012 R2


(X Calibur) #1

Hi,

I'm getting 30 percent load from Filebeat's process alone.
The logs folder has about 1500 files as large as 4MB each.

I tried adding the following the YML config:
harvester_limit: 1
close_inactive: 1m
scan_frequency: 5m
ignore_older: 3h
backoff: 5m
max_procs: 1

Also I wasnt able to find anything abnormal in the log files.
Mainly "Harvester started for file..." lines.

Thanks
Gil


(Pier-Hugues Pellerin) #2

@X_Calibur is there any errors in the log what version of Filebeat are you running?


(X Calibur) #3

No errors whatsoever.
Latest possible version. Downloaded from the past week or so.


(Pier-Hugues Pellerin) #4

I would remove max_procs from the config and just keep harvester_limit,
Would you mind giving us a cpuprofile of the running application using the --cpuprofile my.prof flag described in the doc


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.