Filter Editor do not suggest new value


(Florent) #1

Hi all,

the filter editor doesn't suggest a new value.

and it's not working with several fields like beat.hostname.keyword or fields.instance.keyword.

when i search with this command, it's OK, i have the 3 value expected:

GET my_index/_search 
{
    "aggs" : {
		"uniq_message" : {
			"terms" : { "field" : "fields.instance.keyword" }
		}
	}  
} 

any idea ?
we are running on 6.2.3


(Lukas Olson) #2

Hmm... Do you see any errors in the developer console? Do you get results from the following query?

GET my_index/_search
{
  "size": 0,
  "timeout": "1s",
  "terminate_after": 100000,
  "aggs": {
    "suggestions": {
      "terms": {
        "field": "fields.instance.keyword",
        "execution_hint": "map",
        "shard_size": 10
      }
    }
  }
}

(Florent) #3

Hi @lukas

Well with your query i have only 2 suggestion, i didn't see any error in the developer console

{
  "took": 56,
  "timed_out": false,
  "terminated_early": true,
  "_shards": {
    "total": 6,
    "successful": 6,
    "skipped": 0,
    "failed": 0
  },
  "hits": {
    "total": 600000,
    "max_score": 0,
    "hits": []
  },
  "aggregations": {
    "suggestions": {
      "doc_count_error_upper_bound": 0,
      "sum_other_doc_count": 0,
      "buckets": [
        {
          "key": "NX",
          "doc_count": 597840
        },
        {
          "key": "OLD",
          "doc_count": 2160
        }
      ]
    }
  }
}

(Florent) #4

just for information if i remove "terminate_after" i have all the results expected

{
  "took": 85,
  "timed_out": false,
  "_shards": {
    "total": 6,
    "successful": 6,
    "skipped": 0,
    "failed": 0
  },
  "hits": {
    "total": 1678024,
    "max_score": 0,
    "hits": []
  },
  "aggregations": {
    "suggestions": {
      "doc_count_error_upper_bound": 0,
      "sum_other_doc_count": 0,
      "buckets": [
        {
          "key": "NX",
          "doc_count": 1666824
        },
        {
          "key": "PCE",
          "doc_count": 8652
        },
        {
          "key": "OLD",
          "doc_count": 2548
        }
      ]
    }
  }
}

(Florent) #5

Hi @lukas

have you an idea about this problem ?


(Lukas Olson) #6

@florentmair We put in safeguards when sending the query for suggestions so that users can't take down an entire elasticsearch cluster, which is why you see terminate_after and timeout in there. Unfortunately there isn't a way at the moment to manually configure those settings.


(Florent) #7

after severals days the new value was suggested. Today we have put a new value and the issue still occurs.

Monday, i have upgraded the Elastic Stack to 6.3.0.
What can i do now ?


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.