Filtering Maps into Dashboard Kibana7.4

Hi all,

I'm coming from Kibana 5 and region maps with ISO2 on an index.

In that version, the map was created from an index, so when the map was put into a dashboard, if a filter was applied on a field other than ISO2, that filter was applied on both visualization and maps.

From what I see in Kibana 7.4.0 , the map is not made on from an index alone, but on a join between the map and an index.

In my case, only one index is used to create the dashboard. The map is joined on with this index (containing ISO2, CONTINENTS... ) on map.iso2 = index.ISO2

When I add my map to my dashboard created with the join on the field iso2 from the map with ISO2.keyword (note the uppercase of my field) from my index, I’m not able to filter the dashboard correctly.

Case 1: filtering the dashboard from the map

When I apply a filter on the map, example ISO2 FR, two filter apply by default. "iso2: FR" (from the map field) and "ISO2.keyword: FR. As a result, all visualizations become empty except for the map. When I remove the iso2 filter, the dashboard is correctly filtered but the map is back to its initial state : without any filter.

Expected result: click on FR filter on map => applying FR filter on map and ISO2: FR filter on other visualizations.

Case 2: filtering the dashboard from a visualization other than the map.

When I apply a filter on the a pie with continents, example Europe, one filter is added CONTINENTS.keyword: Europe. All visualizations are filtered correctly but not the map.

Expected result: click on EUROPE filter on pie => applying filter CONTINENTS: EUROPE on visualizations and map

I hope the issue is clear...

Did anyone face the same problem? Am I missing something with Kibana 7 Maps ?

Thanks a lot.

Case 2: filtering the dashboard from a visualization other than the map.

7.6 contains an update allowing users to disable global filters for layer source and joins independently. This will allow you to turn off global filters for the polygon source of your choropleth map while allowing the join to be filtered by the dashboard filter.

Case 1: filtering the dashboard from the map

This is a bug. Disabling global filters for the polygon source should prevent the filter pill from getting created for the polygon source. I have created https://github.com/elastic/kibana/issues/64861 to track.

As a work around, you could use EMS boundaries layer. This way the polygon source is not indexed in Elasticsearch and does not interact with any queries.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.