Filtering percolator queries based on the date range not working

Please check the GIST here

There seems to be a problem with filtering percolator queries based on the
date range given as a date format.

  • nested: PercolateException[failed to percolate]; nested:
    ElasticsearchParseException[failed to parse request]; nested:
    UnsupportedOperationException; " *

I am using the latest version of elastic search 1.4.x. I see this problem
occuring on 1.3.x as well. This should be supported, but doesn't seem like
its working.

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6b5ea0a3-78b7-4768-9b75-3c9c224ec1b8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Found these in the logs. Looks like "PercolateContext.nowInMillisImpl(..)" isn't implemented.

org.elasticsearch.percolator.PercolateException: failed to percolate
at org.elasticsearch.action.percolate.TransportPercolateAction.shardOperation(TransportPercolateAction.java:195)
at org.elasticsearch.action.percolate.TransportPercolateAction.shardOperation(TransportPercolateAction.java:56)
at org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$AsyncBroadcastAction$1.run(TransportBroadcastOperationAction.java:171)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.elasticsearch.ElasticsearchParseException: failed to parse request
at org.elasticsearch.percolator.PercolatorService.parseRequest(PercolatorService.java:363)
at org.elasticsearch.percolator.PercolatorService.percolate(PercolatorService.java:187)
at org.elasticsearch.action.percolate.TransportPercolateAction.shardOperation(TransportPercolateAction.java:192)
... 5 more
Caused by: java.lang.UnsupportedOperationException
at org.elasticsearch.percolator.PercolateContext.nowInMillisImpl(PercolateContext.java:347)
at org.elasticsearch.search.internal.SearchContext.nowInMillis(SearchContext.java:142)
at org.elasticsearch.index.mapper.core.DateFieldMapper.parseToMilliseconds(DateFieldMapper.java:323)
at org.elasticsearch.index.mapper.core.DateFieldMapper.parseToMilliseconds(DateFieldMapper.java:318)
at org.elasticsearch.index.mapper.core.DateFieldMapper.innerRangeQuery(DateFieldMapper.java:350)
at org.elasticsearch.index.mapper.core.DateFieldMapper.rangeQuery(DateFieldMapper.java:345)
at org.elasticsearch.index.query.RangeQueryParser.parse(RangeQueryParser.java:127)
at org.elasticsearch.index.query.QueryParseContext.parseInnerQuery(QueryParseContext.java:277)
at org.elasticsearch.index.query.IndexQueryParserService.innerParse(IndexQueryParserService.java:382)
at org.elasticsearch.index.query.IndexQueryParserService.parse(IndexQueryParserService.java:281)
at org.elasticsearch.index.query.IndexQueryParserService.parse(IndexQueryParserService.java:276)
at org.elasticsearch.percolator.PercolatorService.parseRequest(PercolatorService.java:302)

Found these in the logs. Looks like "PercolateContext.nowInMillisImpl(..)"
isn't implemented.

org.elasticsearch.percolator.PercolateException: failed to percolate
at
org.elasticsearch.action.percolate.TransportPercolateAction.shardOperation(TransportPercolateAction.java:195)
at
org.elasticsearch.action.percolate.TransportPercolateAction.shardOperation(TransportPercolateAction.java:56)
at
org.elasticsearch.action.support.broadcast.TransportBroadcastOperationAction$AsyncBroadcastAction$1.run(TransportBroadcastOperationAction.java:171)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.elasticsearch.ElasticsearchParseException: failed to parse
request
at
org.elasticsearch.percolator.PercolatorService.parseRequest(PercolatorService.java:363)
at
org.elasticsearch.percolator.PercolatorService.percolate(PercolatorService.java:187)
at
org.elasticsearch.action.percolate.TransportPercolateAction.shardOperation(TransportPercolateAction.java:192)
... 5 more
Caused by: java.lang.UnsupportedOperationException
at
org.elasticsearch.percolator.PercolateContext.nowInMillisImpl(PercolateContext.java:347)
at
org.elasticsearch.search.internal.SearchContext.nowInMillis(SearchContext.java:142)
at
org.elasticsearch.index.mapper.core.DateFieldMapper.parseToMilliseconds(DateFieldMapper.java:323)
at
org.elasticsearch.index.mapper.core.DateFieldMapper.parseToMilliseconds(DateFieldMapper.java:318)
at
org.elasticsearch.index.mapper.core.DateFieldMapper.innerRangeQuery(DateFieldMapper.java:350)
at
org.elasticsearch.index.mapper.core.DateFieldMapper.rangeQuery(DateFieldMapper.java:345)
at
org.elasticsearch.index.query.RangeQueryParser.parse(RangeQueryParser.java:127)
at
org.elasticsearch.index.query.QueryParseContext.parseInnerQuery(QueryParseContext.java:277)
at
org.elasticsearch.index.query.IndexQueryParserService.innerParse(IndexQueryParserService.java:382)
at
org.elasticsearch.index.query.IndexQueryParserService.parse(IndexQueryParserService.java:281)
at
org.elasticsearch.index.query.IndexQueryParserService.parse(IndexQueryParserService.java:276)
at
org.elasticsearch.percolator.PercolatorService.parseRequest(PercolatorService.java:302)

On Monday, February 23, 2015 at 2:24:57 PM UTC-8, photonic_world wrote:

Please check the GIST here

https://gist.github.com/photonicworld/890bdda83fb9adcd6e7d

There seems to be a problem with filtering percolator queries based on the
date range given as a date format.

  • nested: PercolateException[failed to percolate]; nested:
    ElasticsearchParseException[failed to parse request]; nested:
    UnsupportedOperationException; " *

I am using the latest version of elastic search 1.4.x. I see this problem
occuring on 1.3.x as well. This should be supported, but doesn't seem like
its working.

Thanks!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/06b4c39a-a433-4f09-bf40-6fa681a15e97%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.