Fleet server agent output not supported

Hello, I just installed elastic stack (with fleet server on the same host) with logstash as output in fleet settings and that was working until I rebooted. Everything seems to work only is the server not listening on port 8220 and the agent appears offline in kibana. I read somewhere on github that output as logstash does not work for fleet server, so i tried to change the output to elasticsearch in elastic-agent.yml but still get the error after restarting the agent:

[elastic_agent][error] Spawned new unit fleet-server-default-fleet-server-fleet_server-084faf10-2ad3-11ee-b6a5-43451818e6af: output not supported
[elastic_agent][error] Spawned new unit fleet-server-default: output not supported
[elastic_agent][error] Spawned new component fleet-server-default: output not supported

I added this to elastic-agent.yml:

    type: elasticsearch
    hosts: []
    username: "elastic"
    password: "password"

Am I missing something?

Hope someone can help, kind regards.

Hi quic22, welcome to the community!

To change the output of a Fleet Server agent (or Fleet managed agents), you have to change the output of the agent policy in Fleet, see the guide how to do it: Elastic Agent policies | Fleet and Elastic Agent Guide [master] | Elastic

Changing the elastic-agent.yml doesn't work for Fleet managed agents.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.