Follow-up question to "Set relative time with timestamp"

I have exactly the same problem as this user specified in this post:

He provided a solution, but it is not clear to me how to specify the Language, Type and format to make the script work.

I assume that the Language is painless, but about the other ones I am not sure.
I have tried out several combinations, but it hasn't worked out so far.

Very thankful for any help!

Painless is correct - the type should be string and the format can be left at default.

Thank you for the answer. It doesn't work so far, but I think the problem lies somewhere else.

If you press the "Get help with the syntax..." link and switch to the "Preview results" tab in the flyout which opens, you can see the specific error you are hitting. Maybe the script is accessing fields that don't exist or something like that.

Thanks for your reply. I still couldn't figure it out, because every time there is just an empty bracket in the preview.
I also tried what is suggested here: Getting empty value in script field in Kibana 5.2.1.

Probably there is a bug in the code which we have to figure out.

Thanks a lot anyways!

Hm, not sure what this is about. Can you make screenshots of what you are seeing?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.