Format index pattern field does not work

I have setup metricbeat, logstash, ES and kibana according to the tutorial https://www.elastic.co/guide/en/elastic-stack-get-started/current/get-started-elastic-stack.html
which works so far as expected.
Now I try to understand how to change the format of a field:
in metricbeats index pattern I changed the format for the field "system.process.memeory.size" to "byte" and the pattern to "0b" .
However still i see this filed in the "discover" panel as e.g. "1.26GB" instead of the expected "1GB" and in the "visualization" panel i set up a "Top N" with Metrics ="Average" for the same field. Here the memory.size values a displays without any formatting , eg. "4,917,970,944" instead of expected "5GB" .
What is missing to make this work?

Hey @bodo.te, which version of Kibana are you using? I'm not seeing the bytes behavior which you report with Discover in Kibana 7.3.

With regard to TSVB, TSVB actually doesn't rely on Kibana's "index patterns", so the formatting which you specify there won't be used by TSVB. https://github.com/elastic/kibana/issues/15875 tracks changing TSVB to use Kibana's "index patterns", so if you'd like to give this issue a +1 or elaborate upon your use-case, it'll help us prioritize this appropriately.

I am using Kibana latest official 7.3. , installed that one just a few days ago on a fresh debian using "deb https://artifacts.elastic.co/packages/7.x/apt stable main'", just as recommended by https://www.elastic.co/guide/en/elasticsearch/reference/current/deb.html, using a self written ansible playbook, so that i can repeat the installation of all of ELK at any time using the official source.

I actually did expect that the TSVB(=Time Series Visual Builder) is relying on Kibana's Index Pattern. Since it seems not (yet) be the case, how can you change the formatting pattern for the TSVB?

Would you mind clicking on the JSON tab in Discover for the document where you're still seeing the system.process.memory.size with the decimals, and replying with the contents here?

23%20PM

I actually did expect that the TSVB(=Time Series Visual Builder) is relying on Kibana's Index Pattern. Since it seems not (yet) be the case, how can you change the formatting pattern for the TSVB?

Under Data -> Options, you can choose a Custom formatter and input your numeral.js formatter:

59%20PM

Regarding the format in Discover - tab:
I played with different format settings in management/kibana/index_patterns : seems sometimes you need to reload the Discover - tab, but sometimes not , to see the change in format.

..and the formating in the Data -> Options worked, too
Thanks a lot!
Bodo

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.