Fuzziness


#1

Hi, I have Kibana 5.3 and in Advanced Settings is "query:queryString:options" and parameter "fuzziness". I would like to diasable it. So I set "fuzziness" to 0. But when I search "jiri" it returns also "giri". How to search only for exact match?
Thank you!


(Lee Drengenberg) #2

Hi,

I did a little testing and I did find and report this bug;

But I'm not sure if it's impacting you. Depends on if you've tried different fuzziness values. If you have, you might need to change your search at least temporarily, do a search, and change it back. And to be sure, close the Histogram chart in Discover and click the Request button to see that it's using the fuzziness value you expect.

That all said, I didn't reproduce your exact problem. If you check the steps above and still don't think you're getting the right results, lets try to make up some simple test data that reproduces the problem.
Please let me know.

Thanks,
Lee

P.S. The issue I found when I delete the setting is a general caching issue, so it would ALSO impact you if you change the fuzziness from one value to another (it wouldn't really change in the query until you changed the search string).


#3

When I run the Kibana console it returns good settings:

"query:queryString:options": """{ "analyze_wildcard": true, "fuzziness" : 0 }"""

In Discovery tab the request is also correct:
"query_string": {
"query": "jiri",
"analyze_wildcard": true,
"fuzziness": 0,
"all_fields": true
}

But result still shows "jiri" and "giri"...

Update: When I search for "*jiri *", it works


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.