Geojson loading error


I've tried several times to load a geojson file into a index through Kibana import system. It gives me the preview of the polygons, creates a index, but the it returns me an error

"Error performing fetch: Request Entity Too Large"

with a doc_count of 0.

I've tried also with a single polygon and the problem was the same. So I guess it a geojson formatting issue. Could you help me with some kind of valid template that I can use?

Thank you

Hi @Hugo_Pires. Can you share the geojson file that you are trying to upload?

Can you also tell us which web browser and version you are using?

Hello @Hugo_Pires. I'd also be interested in what file you're using. My offhand guess would be the file contains some very large features, maybe higher than 30MB or so. We don't see that too often but it does happen. If that's the case, you could try simplifying the file using a utility like


1 Like

Thank you. Is there any way to attach the file to this answer?

My browser is Chrome Version 83.0.4103.61 (Official Build) (64-bit)

@Hugo_Pires You should be able to use this link to provide us the GeoJSON file.


Uploaded files for 0b3fbb16-e893-42ef-93e6-aed9ab6b281c

I guess it's done

Thank you

Thanks @Hugo_Pires. We've received the file. However, I did not get any errors when I used the GeoJSON Upload tool in Kibana v7.7.

Can you share which version of Kibana you are using? Also, can you share any screenshots showing the error?


The version is 7.7.0.

Before import

After import

The index is created with doc_count 0


Thanks @Hugo_Pires. I have a couple more questions.

  1. Are you using a reverse proxy with Kibana?
  2. Are you using Elastic Cloud? If not, how did you deploy Elasticsearch and Kibana?


Are you using a reverse proxy with Kibana? No
Are you using Elastic Cloud? No
If not, how did you deploy Elasticsearch and Kibana? Our instance

I also didn't have any issues loading the file. It looks like the error you're getting is an Elasticsearch-specific error. A few thoughts:

  • You could check in the Elasticsearch forum since it is an Elasticsearch error. I suspect they'll first give you the general advice for this error which is to set an increased value on http.max_content_length. The default is 100MB so that doesn't seem like it would be the issue. With that said, you should certainly give it a shot first so you can say you've tried it. You can find more info here
  • If it isn't too much trouble, you might try upgrading your Elasticsearch instance to 7.7.1 on the off chance it's a bug that was fixed.
  • You can always fall back to a more standard approach to file upload

If neither of the first two options work out, you should consider submitting a bug. There's always the possibility someone else is seeing the same thing whether we can reproduce it or not.


1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.