How to imported file GEOJSON to kibana

hi all,
i have created new layers in kibana maps and i upload my file geojson
but I can't visualize the file
have you any suggestion please

Hi @Khadija_BOUDINAR1

A couple questions , we gonna need a bit more to help.

What version are you on?
Are you running Self Managed or Elastic Cloud?
(I ask because there was a specific bug on a couple versions)

How did you upload the file?
Did the layer show when you tried to add it to the map?
If so was it just the points / features that did not show?

Did you upload straight from the map?
Were there any Errors?

exactly, when I upload my polygon file straight from the maps this error is posted :

i used Self Managed version 8.1.0

Ha!! That is not a very helpful error message... :slight_smile:

Assume you have cleaned up / deleted the index and tried again..

I think that means that your geojson is not "compliant / compatible"

I have seem things like this when the field is an Array of features instead of list of individual features...

can you provide a couple of the features? A small set of the data?

I exported my file in geojson format with the QGIS tool.
would you like me to send you the file?

Well no, as a this is a public forum please do not directly send data files to anyone, especially anything with personal or company confidential information.

If your file can be publicly shared then post a link to pastebin or perhaps a small sanitized subset can be shared here in the forum.

Assumed you used this?

yes i use upload geojson directly , maybe file format is the error???, if I convert it to csv it keeps the geographical aspect or is not a good solution ,

Yup probably a format error / incompatibility ... and no I would not convert to csv...

In your export tool are there any options when you export the GEOJSON?

What happens if you just try to export a single feature?

What happens if you run the GEOJSON through a geojson validator tool?

1 Like

i think I found the solution in fact I re-exported my data again in the QGIS tool in shp then I imported them in the form .SHP is it working, kibana detected the data correctly
thank you for giving me help to change a format

1 Like

Nice! .. But a clarification for us... you loaded .shp directly into elastic or did you convert to geojson first.. (good for me / others to know)

Oh I see the new "File Upload" for shapefiles.. cool! that is pretty recent.


not in elasticserach sorry , but i used a geographic data tool named QGIS where i have exported my data in .shp and then i imported derectly in kibana

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.