Geojson upload hangs on creating index

When uploading a geojson file into a map, Kibana hangs indefinitely on "Writing to index".

It's the same issue as in this fixed bug:

I have Kibana v7.6.1, so it should be fixed in this version.

The index I want to use is one of these (I think this is the website I got it from):

The geojson file is only 1.7 MB. I've had the same problem with all the other geojson files I've tried. I haven't successfully uploaded any geojson files.

If I look in Index Management, the index is present, but it doesn't come up as an option when I make a new map and try to add an index layer.

Hi Kevin,

I could reproduce your error but it's not related with that issue but something different since those datasets are not that big at all.

I've created a report issue in the Kibana repo to try to fix this one.

Sorry for the inconvenience.

@jsanz The file I want to use still isn't working in Kibana.

Previously I found a file for Leeds that works, but it was old boundaries. I can't get the geojson for up-to-date map boundaries to work.

I've processed the attached file with mapshaper. Can you look at it? Why can't Kibana load it? Kibana hangs when writing to index.

This file works:

So I'm able to use this one instead.

It would be interesting to know what the difference is though. The first one seems to have much more detailed bondaries.

That file leeds_wards_extract_fix.geojson is working on my Kibana 7.6.1, you sure it's not being able to load it, have you tried to clean up your indexes and saved objects?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.