Geojson map does not load to elastic index


I'm trying to load a geojson map to an index through the use of 'Maps' in Kibana, and it works for me in one cluster but does not work in the other.
The loading of the file to the index does not come to an end and the index is created but stays empty.

Is there any reason for this behavior?

Hi @Roy_Levy sorry for the inconvenience.

Are both clusters in the same version? Which one? We've seen this behaviour but it really depends on the stack version.

Hey @jsanz ,
It works on 7.6.2 but does not work on elastic cloud version 7.9.3 .

I'm afraid those are old versions and the recommended path would be to upgrade.

If that's not an option you can check from the issue I linked that you can:

  • Try to see if your GeoJSON file can be improved/fixed using the mapshaper command line tool so Kibana Maps is able to index it.
  • Use a different uploading tool instead of Kibana Maps like ogr2ogr as described in this blogpost. A similar process also described in this other post.

Hope it helps

1 Like

Thanks for the information, as for now I can't upgrade the stack version, but it's very unusual because the feature did work excellent on the older version (and with the same geojson files).

I prefer doing it in the same method with the Maps feature, so it'll be the same exactly in both clusters. So for now I'll wait with it until future upgrade/fix.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.